CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Regular Expressions: possible regex problem, not matching: Edit Log



fatalnix
New User

Oct 19, 2008, 3:08 PM


Views: 5351
possible regex problem, not matching

Hi, I have a strange problem. You see, Though I am aware of modules such as POE::Component::IRC and such, I am writing an IRC bot with IO::Socket because I find it to be much more involved, and I needed something that I had complete control over as well as learn the RFC for IRC and concentrate on improving my regex skills. I was unsure either to put this under beginner or regex so please don't flame me for this, I'm unsure of the true problem but think it may be something to do with it-

I made two scripts, one that takes a regex line into an if statement with an actual example, to check that my regex matches correctly, the regex was simply copied and pasted t ensure they were the same.. The test script returns that the regex in fact does match. but in the irc bot script, when it recieves the data, it does not.

(I looked for any posts regarding rules to see if I'm not supposed to put in links, but did not see anything, so please redirect me if I am mistaken)
I sent it to pastebin so it didnt spam 2 pages of the forum:

http://pastebin.com/d2e93505c

I will be happy for anyone who tries to help.

Edit: I forgot to mention something possibly important, the end of /motd regex works and the ident one does, but not join or both privmsg's


(This post was edited by fatalnix on Oct 19, 2008, 3:09 PM)


Edit Log:
Post edited by fatalnix (New User) on Oct 19, 2008, 3:09 PM


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives