CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Advanced: Re: [KevinR] Ask the experts: Edit Log


Apr 3, 2009, 10:15 PM

Views: 16676
Re: [KevinR] Ask the experts

Thanks for the code. I especially enjoyed the tutorial. I commented out a bunch of code within the script I am using. I then applied your coding. At first, it didn't work. Then I found the comment about Linux. Once I applied that code, I was able to upload images onto the server. Mind you, the above took about six hours of trial and error to accomplish. I learned a bunch, and it ended well.

The script I am working with, though, also includes an edit and delete function. Both work... sort of... but the image disappears from the file. I guess that means that my 'commented out' areas are important to the retention of the image in the file.

I have tried to follow the code within my script, and although I understanding more and more, I am still unable to digest it all. In the upload area, the script changes the name of the uploaded file by substituting a unix timestamp in place of the existing file name. That altered file name is what is then uploaded to the server.

The script works perfectly for me at all times. Not so for two other users. The short of it is that: 1. The image is NOT uploaded into the image folder. 2. The image name is NOT changed from that on the local computer. 3. The image name IS stored in the database as the name from the local computer.

So the datafile is written with the unchanged image name, but nothing is uploaded. I would guess that that means that that upload portion of the code is never executed.

Have any clues as to where I should look? I am not against working hard in learning the Perl code, but a push in the right direction could be helpful.

For one of the users all worked well. He updated to Internet Explorer 8 and the image upload stopped working. He restored to the day before the upgrade, and the script once again worked.

By the way, I have Perl v5.8.5 built for i386-linux-thread-multi on the server.

Thanks for everything. Rich

(This post was edited by razman on Apr 3, 2009, 10:20 PM)

Edit Log:
Post edited by razman (Novice) on Apr 3, 2009, 10:20 PM

Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives