CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Beginner: Re: [Pavan Renjal] Can't locate WWW/Mechanize/Firefox.pm in @INC: Edit Log



7stud
Enthusiast

Jan 13, 2013, 9:54 PM


Views: 1344
Re: [Pavan Renjal] Can't locate WWW/Mechanize/Firefox.pm in @INC


Quote
I am a newbie and i need to understand why i am receiving the below error:


You will get the same result if you run a program with this line:


Code
use non_existent;


@INC is a perl array that contains directory names. perl searches in each of those directories for the modules that you specify in a use statement. perl does not look in any other directories. You can see which directories are included in @INC by running this program:


Code
use strict;  
use warnings;
use 5.012;

for (@INC) {
say;
}


But what you really want to know is why didn't cpan install your module correctly. To determine that, you'll have to post some more information. To begin with, you should always post your operating system when asking about installation issues. Also, you should not make readers guess what command you might have used to try and install the module. You should also figure out how to print the version of perl you are using to make sure you are using your perl and not the system perl, something like 'where perl'.


(This post was edited by 7stud on Jan 13, 2013, 9:57 PM)


Edit Log:
Post edited by 7stud (Enthusiast) on Jan 13, 2013, 9:56 PM
Post edited by 7stud (Enthusiast) on Jan 13, 2013, 9:57 PM


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives