CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Beginner: Script, is calling from sub is not working: Edit Log



digioleg54
User

May 3, 2017, 1:43 PM


Views: 1790
Script, is calling from sub is not working

Could you please check, why in my sub, $plscript is not working?

Code
#!/usr/bin/dwebenv perl 

my($lib_path,$data_path);
BEGIN{
$lib_path=$ENV{'DWEB_SITE_PATH'};
$data_path=$ENV{'DWEB_SITE_CGI_DATADIR'};
}
use lib $lib_path.'/lib/web';
use CGI qw(:standard -debug);
use File::Basename;
use FindBin qw( $RealBin);
use DBI;
use Cwd;
use strict;
use warnings;

require 'GetDatesdirs.pl';
my $oracle_user = &db_connect({'DSN'=> 'NYFISWCD'});
my $script = $work_path."/".$prog."job.pl";
my $proc_dt = &set_default_values ($name, $process_date,$oracle_user);
&file_request_user($script, $oracle_user,$process_date)
sub file_request_user
{
my ($plscript, $orauser,$proc_dt) = @_;
print "Content-type: text/html\n\n inside sub\n";
print "$plscript $orauser $process_date\n";
eval {
system ("/versions/perl-5.22.2/bin/perl $plscript $orauser $process_date");
}

}



Thanks


(This post was edited by digioleg54 on May 4, 2017, 12:01 PM)


Edit Log:
Post edited by digioleg54 (User) on May 4, 2017, 12:01 PM


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives