Home: Perl Programming Help: Advanced:
Help needed with perlcc


Aug 16, 2001, 8:09 AM

Views: 2105
Help needed with perlcc

HI, I got some of my programs compiled into bytecode with perlcc -b option. But there's a small problem. When I run the bytecoded copy of the programs, it outputs warnings to STERR whereas original copies do not.

Well, it's not that of a big deal right now. But the problem is perlcc cannot generate me C code. I even tried the simplest hello world script, no use :(.

I keep getting the following output:

[sherzod@cral2 c]$ perlcc hello.pl

Compiling hello.pl:
Making C(hello.pl.c) for hello.pl!
/usr/bin/perl -I/home/sherzod/lib/rrsa/Libraries -I/home/sherzod/lib/rrsa -I/usr/lib/perl5/5.6.0/i386-linux -I/usr/lib/perl5/5.6.0 -I/usr/lib/perl5/site_perl/5.6.0/i386-linux -I/usr/lib/perl5/site_perl/5.6.0 -I/usr/lib/perl5/site_perl -I. -MB::Stash -c hello.pl
/usr/bin/perl -I/home/sherzod/lib/rrsa/Libraries -I/home/sherzod/lib/rrsa -I/usr/lib/perl5/5.6.0/i386-linux -I/usr/lib/perl5/5.6.0 -I/usr/lib/perl5/site_perl/5.6.0/i386-linux -I/usr/lib/perl5/site_perl/5.6.0 -I/usr/lib/perl5/site_perl -I. -MO=C,-umain,-uattributes,-uDB hello.pl
Starting compile
Walking tree
Saving methods
Bootstrap attributes hello.pl
Writing output
Loaded B
Loaded IO
Loaded Fcntl
hello.pl syntax OK
Compiling C(hello) for hello.pl!
/usr/bin/perl -I/home/sherzod/lib/rrsa/Libraries -I/home/sherzod/lib/rrsa -I/usr/lib/perl5/5.6.0/i386-linux -I/usr/lib/perl5/5.6.0 -I/usr/lib/perl5/site_perl/5.6.0/i386-linux -I/usr/lib/perl5/site_perl/5.6.0 -I/usr/lib/perl5/site_perl -I. /tmp/hello.pl.tst
gcc -fno-strict-aliasing -I/usr/lib/perl5/5.6.0/i386-linux/CORE -o hello hello.pl.c -L/usr/local/lib -L/usr/lib/perl5/5.6.0/i386-linux/CORE -lperl -lnsl -ldl -lm -lc -lcrypt /usr/lib/perl5/5.6.0/i386-linux/auto/IO/IO.so /usr/lib/perl5/5.6.0/i386-linux/auto/Fcntl/Fcntl.so
/tmp/cc1f0ESS.o: In function `xs_init':
/tmp/cc1f0ESS.o(.text+0x3459): undefined reference to `boot_DynaLoader'
collect2: ld returned 1 exit status
ERROR: In compiling code for hello.pl.c !

what's wrong here :(. Please, I really need your help now :(

P.S. I also realize that perlcc is "VERY EXPERIMENTAL FEATURE"