Home: General Discussions: Feedback:
Fatal errors



Melvosh
User

Jun 20, 2002, 5:57 AM


Views: 38189
Fatal errors

I've noticed some fatal error messages when I attempt to use the Previous / Next Thread buttons, and when I try to view posts by people who are no longer members. It doesn't happen all the time, but it is frequent. A specific instance:

I was at this URL http://www.perlguru.com/gforum.cgi?do=post_view_threaded;post=16196;sb=post_latest_reply;so=ASC;. I hit the Previous Thread button and got this error:

A fatal error has occurred:

Undefined subroutine &GForum::User::blank_user called at /home/perlguru/webdocs/gfadmin/GForum/Post/View.pm line 324.

Please enable debugging in setup for more details.


Thought someone should know.
"...there's some good in this world, Mr. Frodo, and it's worth fighting for." - Samwise Gamgee, The Two Towers


Jasmine
Administrator

Jun 20, 2002, 9:10 PM


Views: 38186
Re: [Melvosh] Fatal errors

That's odd. I could only duplicate the error when viewing using the threaded mode -- it doesn't happen with the flat mode.

I've removed the previous thread button from the threaded view until this gets straightened out.

Thanks for letting us know.


Melvosh
User

Jul 1, 2002, 6:58 AM


Views: 38173
Re: [Jasmine] Fatal errors

It appears that if I'm in any reply to an initial post, the Next Thread button returns this error:

A fatal error has occurred:

Undefined subroutine &GForum::User::blank_user called at /home/perlguru/webdocs/gfadmin/GForum/Post/View.pm line 324.

Please enable debugging in setup for more details.


Everything works fine in flat mode. Perhaps that'll help solve the problem, or at least point you in the right direction.
"...there's some good in this world, Mr. Frodo, and it's worth fighting for." - Samwise Gamgee, The Two Towers