Home: Perl Programming Help: DBI:
Install DBD::Oracle fails on HP 11.00

New User

Nov 22, 2006, 6:46 AM

Views: 5369
Install DBD::Oracle fails on HP 11.00

 have installed:

# find / -name gcc

-rwxr-xr-x 2 root sys 4371232 Feb 1 2006 /opt/perl/bin/perl
-rwxr-xr-x 2 root sys 3365299 Feb 1 2006 /opt/perl64/bin/perl
lrwxr-xr-x 1 root sys 18 Nov 21 10:47 /usr/bin/perl -> /opt/perl/bin/perl
-r-xr-xr-x 1 bin bin 544768 Nov 7 1997 /usr/contrib/bin/perl

I can not load the DBD-Oracle-1.19 module
When I run:
perl Makefile.PL
Every things seem ok, no complaints.

I added the gcc to my $PATH before I began.
# echo $PATH

When I run make:
Running Mkbootstrap for DBD::Oracle ()
chmod 644 Oracle.bs
rm -f blib/arch/auto/DBD/Oracle/Oracle.sl
/usr/bin/ld +b "/opt/app/oracle/product/8.1.7/lib" -b -L/pro/local/lib Oracle.o dbdimp.o oci8.o -o blib/arch/auto/DBD/Oracle/Oracle.sl \
-L/opt/app/oracle/product/8.1.7/lib -lclntsh -lrt -lpthread \

ld: Mismatched ABI (not an ELF file) for -lclntsh
Fatal error.
*** Error exit code 1


I even tried with the:
perl Makefile.PL -l

I have also tried thru the CPAN console:
I have also tried from the CPAN console:
perl -MCPAN -e shell;

cpan3> install Module DBD::Oracle
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/01base................/usr/lib/dld.sl: Can't shl_load() a library containing Thread Local Storage: /opt/app/oracle/product/8.1.7/JRE/lib/PA_RISC/native_threads/libjava.sl
/usr/lib/dld.sl: Exec format error
Failed to load Oracle extension and/or shared libraries:
install_driver(Oracle) failed: Can't load '/rootuser/.cpan/build/DBD-Oracle-1.19/blib/arch/auto/DBD/Oracle/Oracle.sl' for module DBD::Oracle: Exec format error at /opt/perl/lib/5.8.8/PA-RISC2.0/DynaLoader.pm line 230.
at (eval 3) line 3
Compilation failed in require at (eval 3) line 3.
Perhaps a required shared library or dll isn't installed where expected
at t/01base.t line 19
The remaining tests will probably also fail with the same error.

Failed 20/20 test programs. 11/14 subtests failed.
*** Error exit code 8

/usr/bin/make test -- NOT OK
Running make install
make test had returned bad status, won't install without force
Failed during this command:
PYTHIAN/DBD-Oracle-1.19.tar.gz : make_test NO

Thaumaturge / Moderator

Nov 23, 2006, 4:37 AM

Views: 5366
Re: [lhradowy] Install DBD::Oracle fails on HP 11.00

See this discussion on Perl Monks.

Dave Cross, Perl Hacker, Trainer and Writer
Get more help at Perl Monks