Home: Perl Programming Help: Advanced:
Mechanize:submit_form issue.



perlcoding
New User

Sep 15, 2009, 12:28 AM


Views: 2378
Mechanize:submit_form issue.

Hello People,

I'm running into some issue where in i can't figure out why.Here's whats happening,

The are two links where i'm trying to login,using www::mechanize,

1) http://host:7777/fagcs_302_C600_sfosun05/domain/

2) http://host:7778/fagcs_320_C106_sfoaix04/domain/

The submit_form works perfectly fine for second link but not the first one.

I'm getting this error/status "Couldn't submit form:500::500 Server closed connection without sending any data back".

Please guide me root cause,as to why it would no work for first case?

Please not that,i can manually login to both pages with same usrname and pwd through IE

Please find the code below:

use strict;
use WWW::Mechanize;

my $url = 'http://host:7777/fagcs_302_C600_sfosun05/domain/';
#my $url = 'http://host:7778/fagcs_320_C106_sfoaix04/domain/';
my $username = 'usrname';
my $password = 'pswd';

my $agent = WWW::Mechanize->new();
$agent->get ($url);
#print $agent->content();
if($agent->success()){
eval { $agent->submit_form (
form_number => 0,
fields => {
'j_username' => $username,
'j_password' => $password,
},
);
};
if ($@) {print "error :($@) "; }

print "Couldn't submit form:".$agent->status() .":".":".$agent->content()."\n" unless $agent->success;
}


(This post was edited by perlcoding on Sep 15, 2009, 12:31 AM)


neTTanel
New User

Sep 16, 2009, 8:10 AM


Views: 2353
Re: [perlcoding] Mechanize:submit_form issue.

Hi,

Why not creating a sub that create a $cgi_parameter which will hold the way to connect (view it with http header software) and sent the url with those parameters for login?

This is the way i do those stuff.