Home: Perl Programming Help: Beginner:
Trouble Installing Module

New User

Sep 22, 2012, 9:11 AM

Views: 2949
Trouble Installing Module

Hello, I am trying to follow these [https://github.com/alexrj/Slic3r/wiki/Running-Slic3r-from-git-on-Windows] instructions to install Slic3r from source, but am having problems installing the dependencies. I have installed Citrusperl, and have run the "cpan JSON App::cpanminus" command, but when I try to run "cpanm https://github.com/alexrj/Math-Libm/tarball/master" I get the error "No Perl script found in input. I also tried downloading it and installing it manually, but after running "make" (I already ran perl Makefile.pl) I get the error:

process_begin: CreateProcess(NULL, rem, ...) failed.
make (e=2): The system cannot find the file specified.
make: *** [blibdirs] Error 2

Does anyone know why I'm getting these errors or how I can fix them? Thanks!


Sep 23, 2012, 8:01 AM

Views: 2905
Re: [mcguinnessdr] Trouble Installing Module

pls check the following

perl -v

and the presence of make command

and also...try with nmake/dmake

(This post was edited by kola4help on Sep 23, 2012, 8:04 AM)

New User

Sep 23, 2012, 8:34 AM

Views: 2898
Re: [kola4help] Trouble Installing Module

The dmake command seems to have worked, thank you!