Home: Perl Programming Help: Beginner:
json - how to check if this is installes on opensuse 13.1



dilbert
User

Jul 8, 2014, 12:02 PM


Views: 2790
json - how to check if this is installes on opensuse 13.1

 
json - how to check if this is installes on opensuse 13.1

can i do a check with the terminal


Laurent_R
Veteran / Moderator

Jul 9, 2014, 9:47 AM


Views: 2770
Re: [dilbert] json - how to check if this is installes on opensuse 13.1

Many ways to do it. The simpler might be to try:


Code
% perl -e 'use List::Util;' 

% $perl -e 'use List::Utils;'
Can't locate List/Utils.pm in @INC (@INC contains: /opt/freeware/lib/perl5/5.10.1/ppc-aix-thread-multi /opt/freeware/lib/perl5/5.10.1 /opt/freeware/lib/perl5/site_perl/5.10.1/ppc-aix-thread-multi /opt/freeware/lib/perl5/site_perl/5.10.1 .) at -e line 1.
BEGIN failed--compilation aborted at -e line 1.


Trying to use List::Util succeeds (no error message) because the module is installed, but trying to use List::Utils (which does not exist) gives an error message saying that Perl could not find the module.

Just do the same with your JSON module (you did not specify which one).