CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Intermediate:
using system command

 



rwb7740
stranger

Aug 25, 2001, 4:54 AM

Post #1 of 1 (600 views)
using system command Can't Post

I have written a script to automate all daily activity in our Cognos BI environment. Everything works great, I create a command file with all properly formatted commands to "feed to" a Cognos batch utility program on the NT server. What I thought would be the easy part -- running the batch utility program and passing it the file of commands - has me puzzled at this point. I am using the Perl "system" command to run things. I can't get it to work. I have even resorted to hardcoding paths and names in the program just to see if I can get it to run. If anyone can tell me the stupid mistake I am making (usually is the case) I would really be grateful. Here is how I attempted to run it with hardcoded path/name and it errors out with "The name specified is not recognized as an
internal or external command, operable program or batch file."
my $status = system( "C:\\program files\\cognos\\cer1\\bin\\ppadmtool.exe < D:\\temp\\command_file.txt" );

BTW - I have also tried running all this from a .bat file. I can run batch file from command line - but not from the Perl program.

Thanks - Bob




 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives