CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Intermediate:
IE won't display PDF on redirect()

 



sbatty
stranger

Oct 26, 2001, 7:15 AM

Post #1 of 1 (152 views)
IE won't display PDF on redirect() Can't Post

I did check the FAQ and searched the forums before posting.
So, please don't disregard this as just another redirect question. Here goes;

I have a very simple sub in my script that simply redirects to a url on my server which is a .pdf file. This sub performs as expected in netscape 4.x browsers and opera. It does not, however work in the ie family browsers or netscape 6.

If I change the url to point to an .html file, it works in all browsers. I know what you're thinking but I am not printing a header before the redirect. Also I checked the response header that the server is sending to the browser and the mime type is 'application/pdf'.

The redirect displays only a blank page. Upon first execution of script after reboot of machine, the adobe acrobat splash screen will display. Subsequent executions do not invoke splash screen.

To make things more maddening, this script worked on ie family browsers in early development but stopped after some code changes. My question is does this appear to be code related or is this some kind of browser issue?

Please help.



 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives