CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Other Programming Languages: Javascript:
What am I completely doing wrong here???

 



yapp
User

Apr 16, 2002, 8:02 AM

Post #1 of 5 (24847 views)
What am I completely doing wrong here??? Can't Post

Hi there. I've made some very weird "logic error" in the follow code, that I want to use in a CGI application later. Although It's JavaScript, I would properly make the same error in Perl aswell: Pirate

If you try out the code, you'll see something goes wrong now and then (see attachment).
- Select some names in the first multiselect box.
- Click add
- Select some names in the second multiselect box
- click remove.
- When moving options from one to another select box, the JavaScript will keep the sorting/sequence of the elements identical. (causing the error)
- Repeat that until you get that **** error.

Some combinations seam to result in a weird error. Can anyone explain me why that happens?? Crazy

Yet Another Perl Programmer

_________________________________
~~> [url=http://www.codingdomain.com]www.codingdomain.com <~~
More then 3500 X-Forum [url=http://www.codingdomain.com/cgi-perl/downloads/x-forum]Downloads! Cool

(This post was edited by yapp on Apr 16, 2002, 8:05 AM)
Attachments: testselectboxes.html (5.25 KB)


fashimpaur
User

May 16, 2002, 6:09 AM

Post #2 of 5 (24812 views)
Re: [yapp] What am I completely doing wrong here??? [In reply to] Can't Post

yapp,

I fixed the Javascript so your combo box works correctly now (in my mind
at least). Hope this works well for you.

Good Luck,
Dennis

$a="c323745335d3221214b364d545".
"a362532582521254c3640504c3729".
"2f493759214b3635554c3040606a0",
print unpack"u*",pack "h*",$a,"\n\n";
Attachments: testselectboxes2.html (6.41 KB)


yapp
User

May 16, 2002, 11:21 AM

Post #3 of 5 (24809 views)
Re: [fashimpaur] What am I completely doing wrong here??? [In reply to] Can't Post

Thanks a lot! Smile



I'll look at it, implement this, and see what you changed..

or would you please explain this here...well, i look at the source...anyway

Thanks!

Yet Another Perl Programmer

_________________________________
~~> [url=http://www.codingdomain.com]www.codingdomain.com <~~
More then 3500 X-Forum [url=http://www.codingdomain.com/cgi-perl/downloads/x-forum]Downloads! Cool


yapp
User

May 21, 2002, 10:49 AM

Post #4 of 5 (24796 views)
Re: [fashimpaur] What am I completely doing wrong here??? [In reply to] Can't Post

No, sorry. I still get an error.

Try adding the first, then the fourth, then the second (or third, I can't remember)

I hope you can find the problem...It gives me a headache.

Yet Another Perl Programmer

_________________________________
~~> [url=http://www.codingdomain.com]www.codingdomain.com <~~
More then 3500 X-Forum [url=http://www.codingdomain.com/cgi-perl/downloads/x-forum]Downloads! Cool


fashimpaur
User

May 22, 2002, 8:40 AM

Post #5 of 5 (24793 views)
Re: [yapp] What am I completely doing wrong here??? [In reply to] Can't Post

Sorry I didn't fix that error the first time. I actually found the problem and
fixed it now. Let me know if there are any more bugs.

(File Attached)

Good Luck,
Dennis

$a="c323745335d3221214b364d545".
"a362532582521254c3640504c3729".
"2f493759214b3635554c3040606a0",
print unpack"u*",pack "h*",$a,"\n\n";
Attachments: testselectboxes2.html (6.01 KB)

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives