CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Beginner:
please help with my first aplication !

 



z3phir
New User

Dec 15, 2002, 7:23 PM

Post #1 of 6 (786 views)
please help with my first aplication ! Can't Post

 hi ! i'm new to perl programming and this is my first piece of code. the problem is that when i test my script on my computer it works fine when i upload it to my site it dosen't. i set the permisions ok this is not a problem.

on my computer i use perl.exe parse.pl with the variable my $filenumber = '1';

for online test the variable to get the number i want in this case '1'

my $filenumber = $ENV{'QUERY_STRING'};

http://www.mysite.com/test/parse.pl?1

Please help and scuse my bad english
Attachments: tplates.dat (0.92 KB)
  parse.pl (1.92 KB)


davorg
Thaumaturge / Moderator

Dec 16, 2002, 1:33 AM

Post #2 of 6 (774 views)
Re: [z3phir] please help with my first aplication ! [In reply to] Can't Post

You need to explain why you think it isn't working. What unexpected behaviour do you see? What error messages do you get? Is anything written to the webs server error log?

--
Dave Cross, Perl Hacker, Trainer and Writer
http://www.dave.org.uk/
Get more help at Perl Monks


z3phir
New User

Dec 16, 2002, 5:54 AM

Post #3 of 6 (772 views)
Re: [davorg] please help with my first aplication ! [In reply to] Can't Post

When i run the script on site i get the eror "The server encountered an internal error or misconfiguration and was unable to complete your request. " and only this.
Hope it helps.


davorg
Thaumaturge / Moderator

Dec 16, 2002, 6:12 AM

Post #4 of 6 (770 views)
Re: [z3phir] please help with my first aplication ! [In reply to] Can't Post

I don't see your answer to the question "Is anything written to the webs server error log?"

If you get an "internal server error" message, you'll find the real error message in the web server error log. That's why I suggested that you looked there.

There are some tips on debugging CGI programs in this article.

--
Dave Cross, Perl Hacker, Trainer and Writer
http://www.dave.org.uk/
Get more help at Perl Monks


z3phir
New User

Dec 16, 2002, 6:35 AM

Post #5 of 6 (768 views)
Re: [davorg] please help with my first aplication ! [In reply to] Can't Post

sorry about that. where do i find my server error log ?
i think i know but is almost 2.5mb. I'm from Romania and my connection speed is 2kb/sec that is whay i didn't downloaded the file before.


davorg
Thaumaturge / Moderator

Dec 16, 2002, 6:52 AM

Post #6 of 6 (767 views)
Re: [z3phir] please help with my first aplication ! [In reply to] Can't Post


In Reply To
sorry about that. where do i find my server error log ?

I have no idea. That's completely dependent on how your server is set up. Your sysadmins would know.


In Reply To
i think i know but is almost 2.5mb. I'm from Romania and my connection speed is 2kb/sec that is whay i didn't downloaded the file before.


That's why we have programs like "tail" :)

--
Dave Cross, Perl Hacker, Trainer and Writer
http://www.dave.org.uk/
Get more help at Perl Monks

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives