CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: DBI:
IIS 5.0 and perlscript problem

 



TTMtech
Novice

Mar 24, 2003, 12:33 PM

Post #1 of 2 (2805 views)
IIS 5.0 and perlscript problem Can't Post

Hi,

I have installed IIS 5.0 on windows 2000 server. After that I have installed Activestate distribution from www.activestate.com. I am trying to get data from MS SQL SERVER on web using perl script.Now, my web server gives me following error :

CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:


Can't locate loadable object for module DBI in @INC (@INC contains: D:/Perl/lib D:/Perl/site/lib . c:\InetPub\myttmtech\Admin1) at D:/Perl/site/lib/DBI.pm line 182
BEGIN failed--compilation aborted at D:/Perl/site/lib/DBI.pm line 182.
Compilation failed in require at c:\InetPub\myttmtech\Admin1/ttmtech.pm line 4.
BEGIN failed--compilation aborted at c:\InetPub\myttmtech\Admin1/ttmtech.pm line 4.
Compilation failed in require at C:\inetpub\myttmtech\admin1\index.pl line 6.
BEGIN failed--compilation aborted at C:\inetpub\myttmtech\admin1\index.pl line 6.

What I have to install on web server ? where can I get DBI.PM module and how to install it?

Thanks,

TTMtech


Jasmine
Administrator / Moderator

Mar 26, 2003, 7:54 AM

Post #2 of 2 (2801 views)
Re: [TTMtech] IIS 5.0 and perlscript problem [In reply to] Can't Post

Run ppm.bat (in bin directory where perl.exe lives) and type install DBI

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives