CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Advanced:
apacheCgiPerl

 



new2perl
New User

May 11, 2005, 10:56 AM

Post #1 of 3 (1158 views)
apacheCgiPerl Can't Post

hello!

I cant seem to get my cgi or pl program working with apache...

I get the following Error:


Wed May 11 13:39:27 2005] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't create child process: 720003: prueba.cgi
[Wed May 11 13:39:27 2005] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't spawn child process: C:/Servidor/cgi-bin/prueba.cgi
[Wed May 11 13:39:27 2005] [error] [client 127.0.0.1] File does not exist: C:/Servidor/Apache2/htdocs/favicon.ico
[Wed May 11 13:43:27 2005] [error] [client 127.0.0.1] File does not exist: C:/Servidor/Apache2/htdocs/favicon.ico
[Wed May 11 13:43:31 2005] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't create child process: 720003: prueba.cgi
[Wed May 11 13:43:31 2005] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't spawn child process: C:/Servidor/cgi-bin/prueba.cgi
[Wed May 11 13:43:31 2005] [error] [client 127.0.0.1] File does not exist: C:/Servidor/Apache2/htdocs/favicon.ico
[Wed May 11 13:43:34 2005] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't create child process: 720003: prueba.pl
[Wed May 11 13:43:34 2005] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't spawn child process: C:/Servidor/cgi-bin/prueba.pl
[Wed May 11 13:43:34 2005] [error] [client 127.0.0.1] File does not exist: C:/Servidor/Apache2/htdocs/favicon.ico
[Wed May 11 13:43:47 2005] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't create child process: 720003: prueba.pl
[Wed May 11 13:43:47 2005] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't spawn child process: C:/Servidor/cgi-bin/prueba.pl
[Wed May 11 13:43:47 2005] [error] [client 127.0.0.1] File does not exist: C:/Servidor/Apache2/htdocs/favicon.ico


thanksUnsure


rork
User

May 14, 2005, 2:44 AM

Post #2 of 3 (1119 views)
Re: [new2perl] apacheCgiPerl [In reply to] Can't Post

Well, your problem should be right here:
"The system cannot find the path specified"

The favicon error can be ignored.

It's probably one of these options
1. Your script tries to open a directory or file that can't be found.
2. The file might not exist
3. The alias for your cgi-bin directory is wrong
4. You might have typed the wrong url.

I think it's option 4:
As I can see you tried to reach it 4 different ways:
1. prueba.cgi
2. C:/Servidor/cgi-bin/prueba.cgi
3. C:/Servidor/cgi-bin/prueba.pl
4. prueba.pl

1 and 4 look up pruaba.cgi in the main serverdirectory (htdocs)
2 and 3 won't work, (I don't know what you typed: "localhost/c:/Serveridor/cgi-bin/prueaba.cgi"?)

I think "http://localhost/cgi-bin/prueba.cgi" would be the correct url.
--
Don't reinvent the wheel, use it, abuse it or hack it.


davorg
Thaumaturge / Moderator

May 16, 2005, 6:12 AM

Post #3 of 3 (1092 views)
Re: [new2perl] apacheCgiPerl [In reply to] Can't Post


In Reply To

Code
Wed May 11 13:39:27 2005] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified.  : couldn't create child process: 720003: prueba.cgi



Looks like you have the path to Perl wrong in the shebang line at the top of prueba.cgi.

What happens if you run it from the command line?

--
Dave Cross, Perl Hacker, Trainer and Writer
http://www.dave.org.uk/
Get more help at Perl Monks

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives