CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Beginner:
Help in running the perl script

 



datlaravi
Deleted

Aug 4, 2000, 10:36 PM

Post #1 of 3 (265 views)
Help in running the perl script Can't Post

I am trying to run a perl script on PWS.
I have configured the server to run Perl.
When I run it in the browser,
for example, http://localhost/cgi-bin/test.pl

It is giving the following error.
Can anyone help me what is the problem

HTTP Error 403
403.1 Forbidden: Execute Access Forbidden

This error can be caused if you try to execute a CGI, ISAPI, or other executable program from a directory that does not allow programs to be executed.

Please contact the Web server's administrator if the problem persists.

Thanks


dws
Deleted

Aug 5, 2000, 1:00 PM

Post #2 of 3 (265 views)
Re: Help in running the perl script [In reply to] Can't Post

Launch the "Personal Web Manager" (e.g., by double-clicking on the PWS icon in the system tray). Click the "Advanced" icon. Create a "virtual directory" for cgi-bin by selecting <Home> and clicking Add... Set the Directory to wherever you cgi-bin is, and the Alias to "cgi-bin". Click "Execute" and "Scripts". Click OK. Then try your script again.


datlaravi
Deleted

Aug 9, 2000, 8:21 AM

Post #3 of 3 (265 views)
Re: Help in running the perl script [In reply to] Can't Post

Hi,
I tried creating a virtual directory with alias cgi-bin. It says the directory already exists. I am not able to edit. When I click on edit directory, under alias it is disabled
and it has <HOME>. Please help me how to get
rid of this error
Thanks

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives