CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Win32 Programming Help:
Compiling / Building Perl on Windows Vista


New User

Jul 9, 2007, 11:25 AM

Post #1 of 3 (9492 views)
Compiling / Building Perl on Windows Vista Can't Post

I'm trying to compile Perl 5.8.8 on Windows Vista using Win Vista SDK.

I checked Readme.win32 file to make some adjustments to Makefile under win32 directory.

I performed these steps to compile Perl for Windows Vista:

1) Changed the values of INST_DRV and INST_TOP to specify installation directory.

2) Configured ar value to 'link /lib' for file in win32 directory.

3) Compiled setargv.c to setargv.obj file and enabled USE_SETARGV option to include setargv in Perl binary distribution.

4) Changed CCTYPE option in Makefile to MSVC70FREE to enable Microsoft Win Vista SDK C/C++ compiler.

5) Downloaded fcrypt.c file from site to top level perl directory, and changed CRYPT_SRC option to CRYPT_SRC = fcrypt.c .

6) Downloaded libdes.3.0.6.tar.gz file from same site as step 5, uncompressed file, and compiled source files into a lib file; then changed CRYPT_LIB option to CRYPT_LIB = libdes.lib .

7) Ran nmake tool from win32 directory (nmake /f Makefile), everything worked fine.

8) Tested binary files (nmake /f Makefile test), everything worked fine.

9) Installed binary distribution (nmake /f Makefile install).

10) When try to install binary distribution, an error occurs, html\*.* cannot be copied, to solve this issue I downloaded Perl documentation from site; copied to win32\html directory; and binaries installation worked fine.

11) After binary installation finished, I can see few files in installation directory (perl.exe, perlglob.exe, wperl.exe, and minperl.exe). When try to run any exe file, an error occurs indicating that msvcrt80.dll is missing, but I noticed that perl's dll files are missing in installation directory.

12) I tried to use Perl top level directory where are all binary files that are "running without errors".

13) Now I'm trying to use Perl to compile OpenSSL 098e in windows; when try to perl Configure VC-WIN32 --prefix=c:/openssl/deploy, perl doesn't return output messages and returns empty output files, it seems like perl isn't doing anything. I supposed that maybe crypto files / libraries were wrong, then rebuild perl using cryptopp ( in CRYPT_LIB (CRYPT_LIB = cryptopp.lib) option in Perl's Makefile under win32 directory to use another cryptography library to have different outputs, but I have same results.

I think that I missing something, maybe a dependency, change a makefile option, etc. But I don't know what could be wrong.

These are my resources:

- Windows Vista Ultimate.
- Windows Vista SDK 6.0.
- Perl Source Distribution version 5.8.8 from
- fcrypt.c file from site.
- Libdes cryptography library from site.
- Crypto++ library from site.

Also noticed that date of cryptography files is too old (October 1993, 1994).

I appreciate some help.

Best Regards.


Jul 9, 2007, 11:46 AM

Post #2 of 3 (9491 views)
Re: [daniel_baylon] Compiling / Building Perl on Windows Vista [In reply to] Can't Post

If nobody replies here try


Jul 26, 2007, 12:20 PM

Post #3 of 3 (9436 views)
Re: [daniel_baylon] Compiling / Building Perl on Windows Vista [In reply to] Can't Post

If you just want to program with perl on vista, you can dl the binaries from active state. I have been running perl on vista business using the eclipse IDE and it has worked fine so far. Perl works fine in vista.

New Horizon Designs <-- My site, just updated the GUI to a PHP Nuke interface


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives