CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: General Discussions: General Questions:
LIBGHTTP / HTTP::GHTTP Module

 



Tuzak
New User

Feb 11, 2008, 12:50 PM

Post #1 of 4 (4930 views)
LIBGHTTP / HTTP::GHTTP Module Can't Post

Hello everyone,

I'm trying to install the HTTP::GHTTP module for Perl but keep failing at the first command, the "perl Makefile.PL".

The error message is the following:


Code
running gnome-config... failed 
using fallback values for LIBS and INC
options:
LIBS='-L/usr/local/lib -L/usr/lib -lghttp'
INC='-I/usr/local/include -I/usr/include'
If this is wrong, Re-run as:
$ /usr/bin/perl Makefile.PL LIBS='-L/path/to/lib' INC='-I/path/to/include'

checking for main() in -lghttp... no
libghttp not found
Try setting LIBS and INC values on the command line
Or get libghttp from
ftp://ftp.gnome.org/pub/GNOME/stable/sources/libghttp/


I know after reading the error message its obvious what needs to be done - install libghttp. The thing is, I've installed the libghttp and libghttp-devel via a .RPM but still the same error. I'm using CentOS.

Does any of you guys have any ideas on what I could do next?

Thanks for the help

Tuzak


KevinR
Veteran


Feb 11, 2008, 11:46 PM

Post #2 of 4 (4928 views)
Re: [Tuzak] LIBGHTTP / HTTP::GHTTP Module [In reply to] Can't Post

did you try this suggestion?


If this is wrong, Re-run as:
$ /usr/bin/perl Makefile.PL LIBS='-L/path/to/lib' INC='-I/path/to/include'

You may also want to ask on www.perlmonks.com where there are more active members if you have not all ready.
-------------------------------------------------


Tuzak
New User

Feb 12, 2008, 3:47 AM

Post #3 of 4 (4924 views)
Re: [KevinR] LIBGHTTP / HTTP::GHTTP Module [In reply to] Can't Post

Thanks for the answer.

Yes I tried installing it with that command line, it didn't work either. The error I get when using the command line is:


Code
 running gnome-config... ok 
checking for main() in -lghttp... no
libghttp not found
Try setting LIBS and INC values on the command line
Or get libghttp from
ftp://ftp.gnome.org/pub/GNOME/stable/sources/libghttp/




It seems to find the gnome-config, but not libghttp..

Also, I did not post on perlmonk yet, but I will, thanks for the suggestion.


KevinR
Veteran


Feb 12, 2008, 1:17 PM

Post #4 of 4 (4914 views)
Re: [Tuzak] LIBGHTTP / HTTP::GHTTP Module [In reply to] Can't Post

go with perlmonks, my experience in this area of perl is limited.
-------------------------------------------------

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives