CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Intermediate:
INstalling XML::Parser module

 



ahess
Novice

Feb 5, 2009, 11:03 PM

Post #1 of 3 (549 views)
INstalling XML::Parser module Can't Post

Hi, I'm having difficulty installing the above module on a Ubuntu server 8.0.4, it its complaining about XPAT and the Heavy.pm module. Please Help!


1arryb
User

Feb 25, 2009, 12:39 PM

Post #2 of 3 (511 views)
Re: [ahess] INstalling XML::Parser module [In reply to] Can't Post

Hi ahess,

I don't run ubuntu but I too have had problems installing XML::Parser. A couple of general suggestions.
1. XPAT may not be instlled on your system. You may have to get it via the Ubuntu Linux package manager.
2. Try installing the Heavy.pm module by itself, then retry the XML::Parser install. Sometimes CPAN barfs when it tries to install everything in one go.
3. Say "no" to installing optional modules unless you know you need them. It just complicates the XML::Parser install.

Good luck,

Larry


ahess
Novice

Feb 25, 2009, 10:25 PM

Post #3 of 3 (508 views)
Re: [1arryb] INstalling XML::Parser module [In reply to] Can't Post

Thanks Larry, I actually got it right by installing a new Ubuntu server. I think my old install went corrupt and that is why I coldn't install any module or package without getting errors. My server is running like a dream. Thank you once again.

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives