CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Win32 Programming Help:
win32::Serial Install Problems

 



mshuck
New User

Apr 9, 2009, 8:45 AM

Post #1 of 6 (6413 views)
win32::Serial Install Problems Can't Post

Hey guys,

I'm new to Perl and I have been having some difficulties installing win32:serial module.


So I start like normal

Code
perl makefile.pl


It tells me to run

Code
perl test.pl


Yet me COM1 is not the correct port so I change the port in the t folder and make it COM3 in the default port file

I proceed to test again but it fails the test and when I try to install I receive this


Code
Can't fine html base directory. Edit install.pl manually


I at a lost wondering if you all have any insight?


KevinR
Veteran


Apr 9, 2009, 9:31 AM

Post #2 of 6 (6410 views)
Re: [mshuck] win32::Serial Install Problems [In reply to] Can't Post

If you are using activeperl try using the PPM application that comes with activeperl to install your modules. See the Perl Package Manager documentation that comes with activeperl for details on usage.
-------------------------------------------------


mshuck
New User

Apr 9, 2009, 9:39 AM

Post #3 of 6 (6409 views)
Re: [KevinR] win32::Serial Install Problems [In reply to] Can't Post

I'm using strawberry, but I will give that a try. Thanks


KevinR
Veteran


Apr 9, 2009, 2:03 PM

Post #4 of 6 (6403 views)
Re: [mshuck] win32::Serial Install Problems [In reply to] Can't Post

Ahh, well then don't try using activeperl or PPM if that is the case. You can't easily install two different versions of perl on a Windows box because of the way the registry works. It might be possible but is probably best left for very experienced windows users to figure out.

If you are using strawberry perl you use the CPAN shell to install modules. Is that what you are doing? You may also need dmake or nmake for the installation to work but I am not too familiar with strawberry perl.
-------------------------------------------------


mshuck
New User

Apr 10, 2009, 4:33 AM

Post #5 of 6 (6387 views)
Re: [KevinR] win32::Serial Install Problems [In reply to] Can't Post

I tried using activeperl on my personal machine and still no luck.


No I was using the Command Prompt to install. Reading the readme with the document I don't need to do dmake but instead


Code
perl install.pl


which comes back asking saying


Code
Can't find html base directory. Edit install.pl manually.



KevinR
Veteran


Apr 10, 2009, 10:32 AM

Post #6 of 6 (6380 views)
Re: [mshuck] win32::Serial Install Problems [In reply to] Can't Post

Well, I don't know what the problem might be, sorry. Ask on www.perlmonks.com if you still need help.
-------------------------------------------------

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives