CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Intermediate:
install Net-SSH2 on ppm version 2

 



hem
User

May 14, 2009, 11:32 AM

Post #1 of 15 (2175 views)
install Net-SSH2 on ppm version 2 Can't Post

Ho do i install Net-SSH2 on

PPM> version
2.2.0

This is perl, v5.6.1 built for MSWin32-x86-multi-thread
(with 1 registered patch, see perl -V for more detail)

Copyright 1987-2001, Larry Wall

Binary build 635 provided by ActiveState Corp. http://www.ActiveState.com
Built 15:34:21 Feb 4 2003


KevinR
Veteran


May 14, 2009, 12:04 PM

Post #2 of 15 (2174 views)
Re: [hem] install Net-SSH2 on ppm version 2 [In reply to] Can't Post

Your activeperl installation comes with plenty of documentation. That is the place to check for instructions for that particular version of PPM. You perl install is very old, you might consider an upgrade to 5.8 or 5.10
-------------------------------------------------


hem
User

May 14, 2009, 5:34 PM

Post #3 of 15 (2166 views)
Re: [KevinR] install Net-SSH2 on ppm version 2 [In reply to] Can't Post

Might be a stupid question

But can i upgrade just the ppm version or do i have to upgrade Perl to do so.

Thanks


KevinR
Veteran


May 14, 2009, 9:40 PM

Post #4 of 15 (2161 views)
Re: [hem] install Net-SSH2 on ppm version 2 [In reply to] Can't Post

I'm not sure but I don't think you can upgrade just the PPM application.
-------------------------------------------------


hem
User

May 15, 2009, 8:13 AM

Post #5 of 15 (2151 views)
Re: [KevinR] install Net-SSH2 on ppm version 2 [In reply to] Can't Post

to answer my own question this is what worked

C:\>ppm install http://theoryx5.uwinnipeg.ca/ppmpackages/Net-SSH2.ppd

Thanks


alex_v2
User

May 15, 2009, 8:39 AM

Post #6 of 15 (2149 views)
Re: [hem] install Net-SSH2 on ppm version 2 [In reply to] Can't Post

Really you had to type all that. Most of the time you just have to type the name of the package the way you would in a use statement. So install Net::SSH2 should have worked as well.

-Alexander


KevinR
Veteran


May 15, 2009, 8:52 AM

Post #7 of 15 (2147 views)
Re: [alex_v2] install Net-SSH2 on ppm version 2 [In reply to] Can't Post


In Reply To
Really you had to type all that. Most of the time you just have to type the name of the package the way you would in a use statement. So install Net::SSH2 should have worked as well.

-Alexander


He is using PPM to install the module from a repository that is not listed in his repository list (I assume). So he has to type the full name of the repository to tell "install" where to get the module. If he adds theoryx5.uwinnipeg.ca to his list of repositories then he can skip typing the repository name.
-------------------------------------------------


FishMonger
Veteran / Moderator

May 15, 2009, 8:53 AM

Post #8 of 15 (2146 views)
Re: [alex_v2] install Net-SSH2 on ppm version 2 [In reply to] Can't Post


In Reply To
Really you had to type all that. Most of the time you just have to type the name of the package the way you would in a use statement. So install Net::SSH2 should have worked as well.

-Alexander


Provided http://theoryx5.uwinnipeg.ca/ppmpackages was added to the list of repositories. ActiveState doesn't include it in the base install.


alex_v2
User

May 15, 2009, 8:58 AM

Post #9 of 15 (2143 views)
Re: [FishMonger] install Net-SSH2 on ppm version 2 [In reply to] Can't Post

Well Fish you would know much better then me I am sure as I hardly ever touch active state perl. I always use the CPAN mod on *nix systems so if you can find it on cpan you can install it by package name hehe.

Also thanks for the info as I didn't know it worked that way.

-Alexander


(This post was edited by alex_v2 on May 15, 2009, 8:59 AM)


KevinR
Veteran


May 15, 2009, 9:11 AM

Post #10 of 15 (2141 views)
Re: [FishMonger] install Net-SSH2 on ppm version 2 [In reply to] Can't Post


In Reply To

In Reply To
Really you had to type all that. Most of the time you just have to type the name of the package the way you would in a use statement. So install Net::SSH2 should have worked as well.

-Alexander


Provided http://theoryx5.uwinnipeg.ca/ppmpackages was added to the list of repositories. ActiveState doesn't include it in the base install.


There he goes, repeating me again...... CoolWink
-------------------------------------------------


FishMonger
Veteran / Moderator

May 15, 2009, 9:32 AM

Post #11 of 15 (2138 views)
Re: [KevinR] install Net-SSH2 on ppm version 2 [In reply to] Can't Post


In Reply To

In Reply To

In Reply To
Really you had to type all that. Most of the time you just have to type the name of the package the way you would in a use statement. So install Net::SSH2 should have worked as well.

-Alexander


Provided http://theoryx5.uwinnipeg.ca/ppmpackages was added to the list of repositories. ActiveState doesn't include it in the base install.


There he goes, repeating me again...... CoolWink


Does that mean that we are each others "broken record"? Wink


KevinR
Veteran


May 15, 2009, 12:19 PM

Post #12 of 15 (2132 views)
Re: [FishMonger] install Net-SSH2 on ppm version 2 [In reply to] Can't Post


In Reply To

In Reply To

In Reply To

In Reply To
Really you had to type all that. Most of the time you just have to type the name of the package the way you would in a use statement. So install Net::SSH2 should have worked as well.

-Alexander


Provided http://theoryx5.uwinnipeg.ca/ppmpackages was added to the list of repositories. ActiveState doesn't include it in the base install.


There he goes, repeating me again...... CoolWink


Does that mean that we are each others "broken record"? Wink


Maybe a scratch CD? Most of the younger members may not know what a record is.... Unsure
-------------------------------------------------


FishMonger
Veteran / Moderator

May 15, 2009, 12:55 PM

Post #13 of 15 (2129 views)
Re: [KevinR] install Net-SSH2 on ppm version 2 [In reply to] Can't Post


Quote
Maybe a scratch CD? Most of the younger members may not know what a record is...


I can remember 78's and 45's. In fact I have a large collection of them, but my stylus is broken. Frown


KevinR
Veteran


May 15, 2009, 2:48 PM

Post #14 of 15 (2127 views)
Re: [FishMonger] install Net-SSH2 on ppm version 2 [In reply to] Can't Post


In Reply To

Quote
Maybe a scratch CD? Most of the younger members may not know what a record is...


I can remember 78's and 45's. In fact I have a large collection of them, but my stylus is broken. Frown


Sell them on eBay!

I have LPs (33 1/3) from the 70's and a little into the 80's, maybe 50. I still have a turntable (with a good stylus even) although I haven't hooked it all up in years.
-------------------------------------------------


hem
User

May 18, 2009, 8:10 AM

Post #15 of 15 (2113 views)
Re: [KevinR] install Net-SSH2 on ppm version 2 [In reply to] Can't Post

sorry to break the interesting thread but that's correct that I has to give the full name since i did not has that repo installed

Thanks

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives