CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: DBI:
Installing DBI - help!

 



andy_wood
Novice

Jun 15, 2009, 5:20 AM

Post #1 of 2 (3755 views)
Installing DBI - help! Can't Post

Hi everyone.

I am trying to install the DBI module for perl on Linux Redhat. I tried installing from http://search.cpan.org/~timb/DBI/DBI.pm but when I tried running my script I got the following message:

Can't load '/opt/ActivePerl-5.8/site/lib/auto/DBI/DBI.so' for module DBI: /opt/ActivePerl-5.8/site/lib/auto/DBI/DBI.so: cannot open shared object file: No such file or directory at /opt/ActivePerl-5.8/lib/DynaLoader.pm line 230.
at /opt/ActivePerl-5.8/site/lib/DBI.pm line 263
BEGIN failed--compilation aborted at /opt/ActivePerl-5.8/site/lib/DBI.pm line 263.
Compilation failed in require at snp_chaser_1014_15062009.pl line 114.
BEGIN failed--compilation aborted at snp_chaser_1014_15062009.pl line 114.


So then I tried installing the bundle from http://search.cpan.org/dist/DBD-mysql/lib/Bundle/DBD/mysql.pm but when I try to run the command i get the follwoing error:

...

DBI is up to date.
Running install for module DBD::mysql
Running make for C/CA/CAPTTOFU/DBD-mysql-4.011.tar.gz
Is already unwrapped into directory /root/.cpan/build/DBD-mysql-4.011

CPAN.pm: Going to build C/CA/CAPTTOFU/DBD-mysql-4.011.tar.gz

Can't load '/opt/ActivePerl-5.8/site/lib/auto/DBI/DBI.so' for module DBI: /opt/ActivePerl-5.8/site/lib/auto/DBI/DBI.so: cannot open shared object file: No such file or directory at /opt/ActivePerl-5.8/lib/DynaLoader.pm line 230.
at /opt/ActivePerl-5.8/site/lib/DBI.pm line 263
BEGIN failed--compilation aborted at /opt/ActivePerl-5.8/site/lib/DBI.pm line 263.
Compilation failed in require at /opt/ActivePerl-5.8/site/lib/DBI/DBD.pm line 3225.
BEGIN failed--compilation aborted at /opt/ActivePerl-5.8/site/lib/DBI/DBD.pm line 3226.
Compilation failed in require at Makefile.PL line 23.
Running make test
Make had some problems, maybe interrupted? Won't test
Running make install
Make had some problems, maybe interrupted? Won't install
Bundle summary: The following items in bundle Bundle::DBD::mysql had
installation problems:
DBD::mysql


This error also occurred when I tried installing the bundle using

perl -MCPAN -e shell

install Bundle::DBD::mysql




What do I need to do to correct this?

Thanks,


raxip
Novice

Jun 16, 2009, 9:49 AM

Post #2 of 2 (3743 views)
Re: [andy_wood] Installing DBI - help! [In reply to] Can't Post

Just by quickly looking at your errors, it appears that you're missing the DynaLoader module. Have you tried seeing if it's already installed on your system? If not, you should consider satisfying that dependency first.

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives