CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Beginner:
using SOAP::WSDL::Client



Jul 20, 2009, 10:15 AM

Post #1 of 1 (844 views)
using SOAP::WSDL::Client Can't Post

As am trying to test how SOAP::WSDL::Client works. Following the documentation on my test code as follows:

#!perl -w

use SOAP::WSDL::Client;

my $soap = SOAP::WSDL::Client->new({
proxy => 'http://localhost/PerlTest/Service1.asmx'

my $result = $soap->call('HelloWorld', );

print $result;

Service1.asmx is my test webservice in .Net. I am not getting the appropriate result. The output is:


C:\Documents and Settings\testUser\My Documents\My Website>perl
Use of uninitialized value in exists at C:/Perl/site/lib/SOAP/WSDL/Expat/Message line 42.
Use of uninitialized value in hash element at C:/Perl/site/lib/SOAP/WSDL/Expat/M line 50.
<Fault xmlns=""><faultcode>soap:Server<
/faultcode><faultstring>Error deserializing message: Can&apos;t call method &quo
t;get_typemap&quot; on an undefined value at C:/Perl/site/lib/SOAP/WSDL/Expat/Me line 53.
Message was:
&lt;?xml version=&quot;1.0&quot; encoding=&quot;utf-8&quot;?&gt;&lt;soap:Envelop
e xmlns:soap=&quot;; xmlns:xsi=&qu
ot;; xmlns:xsd=&quot;http://www.w3
oapException: Server did not recognize the value of HTTP Header SOAPAction: .
at System.Web.Services.Protocols.Soap11ServerProtocolHelper.RouteRequest()
at System.Web.Services.Protocols.SoapServerProtocol.RouteRequest(SoapServerMe
ssage message)
at System.Web.Services.Protocols.SoapServerProtocol.Initialize()
at System.Web.Services.Protocols.ServerProtocolFactory.Create(Type type, Http
Context context, HttpRequest request, HttpResponse response, Boolean&amp;amp; ab
ortProcessing)&lt;/faultstring&gt;&lt;detail /&gt;&lt;/soap:Fault&gt;&lt;/soap:B

Thank you.


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives