CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Advanced:
`CMD` not working on 64bit platform

 



ajitnavasare
Novice

Nov 5, 2009, 2:33 AM

Post #1 of 2 (2950 views)
`CMD` not working on 64bit platform Can't Post

Hi all,
I am facing a problem, my scripts works well on Win2k3 32 bit platform (active perl 5.8.8,primal Script) but on win2k3 64bit I have an issue when I use “ `reg query hklm\software\someappname\cregs 1> dataf.txt 2>&1` ” I get the O/P as “ERROR: The system was unable to find the specified registry key or value.” But if I execute the same CMD from command line I get the proper O/P. and more over the same script works well on 32 bit platform with out any error.
Can any one help me in the above issue?
Thanks in advance.


FishMonger
Veteran / Moderator

Nov 5, 2009, 4:04 AM

Post #2 of 2 (2947 views)
Re: [ajitnavasare] `CMD` not working on 64bit platform [In reply to] Can't Post

It would be better to use a module that is designed to work with the registry.

Win32::TieRegistry - Manipulate the Win32 Registry
http://search.cpan.org/~adamk/Win32-TieRegistry-0.26/lib/Win32/TieRegistry.pm

However, I have not used it on a 64bit system, so the underlying system dll libraries that it uses may not be on your system.

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives