CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Advanced:
passing XML to webservice as input

 



ifazlives
New User

Nov 24, 2009, 9:14 AM

Post #1 of 1 (1624 views)
passing XML to webservice as input Can't Post

Perl Gurus,

Please help me with this issue. I have been working on it for a loooong time.

I am trying to pass an XML request into a webservice using SOAP::Lite. The WSDL file is expecting an XML Document as the input.

I have been tracing the SOAP::Lite and my XML is tampered in the SOAP Request envelop.

Here is a part of my code.

my $parser = XML::DOM::Parser->new();
my $doc = $parser->parsefile(pushUserAccountStatus.xml');
my $root = $doc->getDocumentElement();


$soap = SOAP::Lite->new( proxy => 'http://www.abc.com/ASR-dev/OnlineInterface.cfc?wsdl');
$result=$soap->call('PushUserAccountStatus', $xmlstring );# SOAP::Data->value($root->toString));


-------------------------------

TRACE OUTPUT...


<?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/1999/XMLSchema"><SOAP-ENV:Body><PushUserAccountStatus><c-gensym5 xsi:type="xsd:string">&lt;pushUserAccountStatus systemEnvironmentCode="ASR-Dev" version="1.0">
&lt;applicationArea>
&lt;applicationID>lawson&lt;/applicationID>
&lt;creationDateTime>Tue Nov 24 15:59:40 2009&lt;/creationDateTime>
&lt;/applicationArea>
&lt;dataArea>
&lt;userDetails>
&lt;ticketInfo>
&lt;requestid>83622&lt;/requestid>
&lt;dateRequestSent>2009/11/24&lt;/dateRequestSent>
&lt;implementaionStatus>Success&lt;/implementaionStatus>


hERE all the "<" IS Converted to &lt; .. Please tell me a method to prevent this.

Or is there any other way to pass XML as an argument to a webservice.

Why does it only convert "<" instead of both "<" and ">"

Please Please help me....

-iFAZ

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives