CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Beginner:
what 's wrong?

 



xubaoguo
New User

Dec 3, 2009, 4:39 AM

Post #1 of 1 (579 views)
what 's wrong? Can't Post

I want to integrate Bugzilla with Apache HTTPD 2.0.45 on W2K professional.

The bugzilla is stored in c:\bugzilla, and the Perl is installed on c:\perl

the checksetup.pl passed.

The followin is the setting I added in httpd.conf of Apache Server:

ScriptAlias /bugzilla/ "C:/bugzilla/"

<Directory "C:/bugzilla">
Options +ExecCGI +FollowSymLinks
AllowOverride Limit
DirectoryIndex index.cgi
</Directory>

AddHandler cgi-script .cgi pl


When I access bugzilla using http://localhost/bugzilla/index.cgi, I got the
"internal Server Error", The error message in error.log is
[Wed Feb 04 15:03:25 2004] [error] [client 127.0.0.1] (OS 3)The system
cannot find the path specified. : couldn't create child process: 720003:
index.cgi
[Wed Feb 04 15:03:25 2004] [error] [client 127.0.0.1] (OS 3)The system
cannot find the path specified. : couldn't spawn child process:
C:/bugzilla/index.cgi

The first line in index.cgi is
#!/usr/bin/perl -w

I try to change it to:
#!C:/perl/bin
I got the error message in error.log as:
[Wed Feb 04 15:13:03 2004] [error] [client 127.0.0.1] (OS 5)Access is
denied. : couldn't create child process: 720005: index.cgi
[Wed Feb 04 15:13:03 2004] [error] [client 127.0.0.1] (OS 5)Access is
denied. : couldn't spawn child process: C:/bugzilla/index.cgi

What's worng with the configuration in httpd.conf

Thank very much for your help.

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives