CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Intermediate:
Using LWP and it hangs on the get command



Dec 7, 2009, 3:42 PM

Post #1 of 2 (1052 views)
Using LWP and it hangs on the get command Can't Post

I am trying to use the LWP model on 5.004_04 solaris 9. This script works fine from a machine located in a different domain.

When I run this script on a machine within the same domain as the server, it just hangs. I thought it was the apache server, but it isn't since the script works if I run it from a machine in another country.

Is there some server setting that could be blocking the request? I'm not sure how to debug this. Thanks for any help.


use LWP::Simple;

$content = get "http://<servername>:8001/toolname/"

print $content;


Dec 8, 2009, 9:17 AM

Post #2 of 2 (1022 views)
Re: [srhadden] Using LWP and it hangs on the get command [In reply to] Can't Post

Disregard. I determined that the server had other issues, unable to telnet or ping. The hosts file was not updated since it was moved recently.

Problem fixed. Not a perl issue.




Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives