CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: General Discussions: General Questions:
Need Help with PERL Forums (WebBBS)

 



Stick
New User

Feb 22, 2010, 12:01 PM

Post #1 of 2 (4261 views)
Need Help with PERL Forums (WebBBS) Can't Post

 
Let me thank anyone up front who takes the time to read all this and try to help me out either by investigating or by referring me to a better place to try.

I run a web site, http://www.bgonline.org, a web site about backgammon, and on the site I have forums which are the main draw of the site. (http://www.bgonline.org/forums/) The forums are a PERL based cgi bulletin board called WebBBS. (http://awsd.com/scripts/webbbs/) The site/forums have been up and running for roughly 3-4 years now.

The site itself is still accessible but the forums are down. If you visit them it acts as if the database has been deleted or it can't see it. All the old posts should be accessible but they are not. They are still in the database, I can access them through the cpanel, but nobody is able to post and nobody is able to read the old posts. When one tries to access what should be the forums main page you're told you need to create a profile and there is no listing of posts. If I try to get to the administration configuration to rebuild the database for example, I'm given the error message of "The script was unable to open the message database file. This is most likely due to a permissions error in the data directory".

I had not recently changed anything as far as my site or forums is concerned. Nothing should have happened but suddenly, the forums were gone for the public. They have been down for 4 full days now. I have contacted my hosting company, vps.net. Initially regular support tried who knows what and had no success. They suggested I use their 'pay support'. Fine, it's $10/day, I opened a ticket 3 days ago and they were spectacularly unsuccessful. Their last suggestion was to find someone who knows PERL, apparently nobody on their team does. They even said they had a backup from about 3 months ago and tried using it and it didn't work.

I have the most up to date WebBBS installed and I have tried downloading the original files and comparing all the important ones to what I have on the site. Everything appears to be in order and I'm at a loss as to what I should try next. I'm competent enough with a computer but am no programmer. Any suggestions? If I need to provide any further information just ask.

Thanks.

Stick


FishMonger
Veteran / Moderator

Feb 22, 2010, 1:41 PM

Post #2 of 2 (4258 views)
Re: [Stick] Need Help with PERL Forums (WebBBS) [In reply to] Can't Post

The scripts for that BBS package are very poorly written and troubleshooting them from scratch is beyond the scope of this or any other Perl forum.

If you truly didn't make any changes, then your host must have made some changes to the server that broke your scripts.

My suggestion is to hire a Perl programmer that can debug the scripts. Proper troubleshooting will require shell access to your files and the programmer will need to have full access to your account. Do you have shell access?

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives