CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Intermediate:
Mailing List

 



perlkid
stranger

Sep 27, 2000, 1:35 AM

Post #1 of 1 (413 views)
Mailing List Can't Post

 
Problem Sovled, I Had one of the hidden values in the form wrong and the code wasn't even being initiated. OOps, Smile Thanks Any, Sorry For Wasting Space.
---------------------------------------------------------


Hi Everyone,

I have a list of e-mail addresses in an array. When I loop through the array and print mail to the addresses it doesn't send the mail. I simply put my own e-mail address in there about 8 times for testing purposes.

What I'm doing right now is this

<BLOCKQUOTE><font size="1" face="Arial,Helvetica,sans serif">code:</font><HR>


foreach $line (@all){
(@info)=split(/\|\^\|/, $line);
open (MAIL, "| $mailprog -t -oi") | | print "Can't send mail, Reason: $!";
print MAIL "To: $info[7]\n";
print MAIL "Reply-to: $form{'from'}\n";
print MAIL "From: $in{'from'}\n";
print MAIL "Subject: $in{'subject'}\n";
print MAIL "Message:\n\n";
print MAIL "$in{'message'}\n";
close (MAIL);
}#end of foreach
</pre><HR></BLOCKQUOTE>

Am I doing something wrong here, or is the problem due to a mistake in hadling the data or something else?

Thanks,

perlkid

[This message has been edited by perlkid (edited 09-27-2000).]

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives