CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Intermediate:
Illegal Seek from CGI script



Nov 3, 2000, 3:07 AM

Post #1 of 3 (338 views)
Illegal Seek from CGI script Can't Post

I've tried to run the script as myself and as httpd offline, it works ok. In normal use via a web client, the script returns nothing, and logs an "illegal seek" error.

This is probably as much Unix as Perl, but I'd be grateful for any help.

The script is a simple interface to a shell script, which in turn extracts information from a large database of text(SGML) files.


Nov 4, 2000, 9:53 PM

Post #2 of 3 (338 views)
Re: Illegal Seek from CGI script [In reply to] Can't Post

Give us something better to go on. Try to reduce your CGI to the smallest example that will demonstrate the problem, and post it. (Often, that exercise is enough to pinpoint the problem.)

A wild guess. Are you trying to treach an ascii file as though it were binary? You may need to use binmode() for avoid forcing newline conversions.


Nov 9, 2000, 2:06 AM

Post #3 of 3 (338 views)
Re: Illegal Seek from CGI script [In reply to] Can't Post

Got some help with this. The PATH wasn't set to include all necessary files, got it to work by setting it with


I didn't suspect this because the script worked fine as when logged in as httpd. Also, it worked a week ago then stopped working abruptly. I guess an admin had mucked around with the server or summit.

Thanks anyway.


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives