CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Advanced: Makefile.PL broken?


New User

Mar 2, 2011, 3:58 AM

Post #1 of 2 (2894 views) Makefile.PL broken? Can't Post

Hi all

I have been using GD for a while now and I'm now trying to install GD-2.45 from CPAN.

I want it with GIF, PNG and JPEG support but that doesn't seem be getting installed by default.

I downloaded locally and after untarring tried:
perl Makefile.PL -lib_png_path=/usr/lib/ -lib_jpeg_path=/usr/lib/

these are the locations of the shared object files on my CentOS 5.5

but I get:
[root@pluto GD-2.45]# perl Makefile.PL -lib_png_path=/usr/lib/ -lib_jpeg_path=/usr/lib/
Unknown option: lib_png_path
Unknown option: lib_jpeg_path

I also tried:
[root@pluto GD-2.45]# perl Makefile.PL -options "JPEG,PNG,GIF"
Unknown option: options

Is Makefile.PL broken or am I doing something wrong?

In the past,
make install

used to do the trick

Now what?

Thanks for any replies

New User

Mar 2, 2011, 8:52 AM

Post #2 of 2 (2886 views)
Re: [monx663] Makefile.PL broken? [In reply to] Can't Post

The Makefile.PL in GD is broken! This is apparently a known issue. Look in CPAN and you'll see.

I applied the patch recompiled and hey presto!


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives