CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Intermediate:
apache + gmaps

 



OneDreamCloser
New User

Apr 16, 2011, 7:54 AM

Post #1 of 1 (1155 views)
apache + gmaps Can't Post

hello all,

this is my 1st app that will run on an apache server and it is based on google maps. the problem is that while i can open the .html file (together with a bit of javascript code) and see it running
i cannot do that when i have a .perl-cgi script instead of the .html file.
i use the default apache server install on mac os x, the root directory i use for the .chi script is the default one "/Library/WebServer/CGI-Executables" (please note that the Hello World chi script works just fine).
so when i type "http://localhost/cgi-bin/demo.cgi" i am getting the following:
Failed to load resource: the server responded with a status of 404 (Not Found) ---> demo.js
Failed to load resource: the server responded with a status of 404 (Not Found) ---> favicon.ico
and the "/var/log/apache2/error_log" complains only for the favicon thing.

attached is the simple app i am using, so if you could tell me if you are able to run it and how you did it, it would very informative.
i am in a desperate need to make this work, so i would appreciate your help.

thank you.
Attachments: demo.cgi (0.82 KB)
  demo.js (1.22 KB)
  demo.shtml (0.71 KB)

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives