CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Beginner:
"Could not find gdlib-config" ..? Need help using modules...


New User

Oct 17, 2011, 11:43 PM

Post #1 of 1 (2849 views)
"Could not find gdlib-config" ..? Need help using modules... Can't Post

I'm quite new at Perl, and I'm having some difficulties with what seems to be uberbasic.

I tried using a module, GD::Simple, which I of couse had to download and install. I tried following numerous guidelines that I found from various sources online in order to do this properly, but none of them seem to produce the desired outcome. The closest I seem to have gotten so far is an unpacked GD-2.46 folder with all sorts of stuff in it - but when I try to make it using the Makefile, I get the error:

Could not find gdlib-config in the search path. Please install libgd 2.0.28 or higher.

If it makes a difference, no matter how I try to install it, I continue to get this error when trying to compile/run my program:

Can't locate GD/ in @INC (@INC contains: /Library/Perl/Updates/5.10.0 /System/Library/Perl/5.10.0/darwin-thread-multi-2level /System/Library/Perl/5.10.0 /Library/Perl/5.10.0/darwin-thread-multi-2level /Library/Perl/5.10.0 /Network/Library/Perl/5.10.0/darwin-thread-multi-2level /Network/Library/Perl/5.10.0 /Network/Library/Perl /System/Library/Perl/Extras/5.10.0/darwin-thread-multi-2level /System/Library/Perl/Extras/5.10.0 .) at line 1.
BEGIN failed--compilation aborted at line 1.

Please help! ): I don't know how to use any modules at this point... This is becoming exasperating.

Thank you! :) Much appreciated.


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives