CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: DBI:
Redmine installation, DBI issue

 



simone.marcato
New User

Nov 3, 2011, 8:53 AM

Post #1 of 2 (16858 views)
Redmine installation, DBI issue Can't Post

Hello,

I don't now if this is the right place for asking

I'm trying to install redmine and give svn access to users, my apache configuration is the following:


Code
LoadModule perl_module /usr/lib64/httpd/modules/mod_perl.so 
PerlLoadModule Apache::Redmine

<Location />

LoadModule dav_svn_module /usr/lib64/httpd/modules/mod_dav_svn.so
DAV svn

SVNParentPath "/opt/svn"
SVNListParentPath On
Order deny,allow
Satisfy any

AuthType Basic
AuthName "Filoblu SVN Repository"
#AuthUserFile /home/filo02/public_html/svn/svn.passwd
PerlAccessHandler Apache::Authn::Redmine::access_handler
PerlAuthenHandler Apache::Authn::Redmine::authen_handler

Require valid-user
Allow from 50.22.178.181
Allow from 127.0.0.1

Satisfy any
Require valid-user

RedmineDSN "DBI:mysql:database=filo02_redmine_production;host=localhost"
RedmineDbUser "filo02_redmine"
RedmineDbPass "tW0]^[T=Ps*4"
</Location>


but when I try to start apache it gave this error:

Code
Can't load '/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/DBI/DBI.so' for module DBI: /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/DBI/DBI.so: undefined symbol: PL_tainting at /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/DynaLoader.pm line 230. 
at /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/DBI.pm line 269
BEGIN failed--compilation aborted at /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/DBI.pm line 269.
Compilation failed in require at /usr/lib/perl5/site_perl/Apache/Redmine.pm line 101.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/Apache/Redmine.pm line 101.
Compilation failed in require at (eval 2) line 3.


searching in the web I've only found people saying that is a perl problem.

I'm a newbie to perl so after few days trying to fix this I have not managed to fix, I hope someone can help me


FishMonger
Veteran / Moderator

Nov 3, 2011, 12:21 PM

Post #2 of 2 (16846 views)
Re: [simone.marcato] Redmine installation, DBI issue [In reply to] Can't Post

See if this helps.
http://modperlbook.org/html/22-2-6-Can-t-load-auto-DBI-DBI-so-for-module-DBI.html

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives