CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Advanced:
minicpan puzzle

 



bluedome
New User

Sep 14, 2012, 1:40 PM

Post #1 of 2 (3128 views)
minicpan puzzle Can't Post

 
I created a local cpan mirror with minicpan. But when I install perl modules pulling only from my local mirror, it cannot find Template::Toolkit. When I look in the relevant portion of the packages file, it looks like this:


Code
Template::Timer                    1.00  P/PE/PETDANCE/Template-Timer-1.00.tar.gz 
Template::Tiny 1.12 A/AD/ADAMK/Template-Tiny-1.12.tar.gz
Template::Toolkit::Simple 0.16 I/IN/INGY/Template-Toolkit-Simple-0.16.tar.gz
Template::Trivial 0.08 S/SC/SCOTTW/Template-Trivial-0.08.tar.gz
Template::TT2Site 1.46 J/JV/JV/Template-TT2Site-0.95.tar.gz
Template::TT2Site::Plugin::Mapper 1.02 J/JV/JV/Template-TT2Site-0.95.tar.gz
Template::Utils 1.08 A/AB/ABW/Template-Toolkit-1.07.tar.gz
Template::View 2.91 A/AB/ABW/Template-Toolkit-2.24.tar.gz


There is no Template::Toolkit in the first column, even though it evidently found Template::Toolkit because it is present in the author section under Template::View.

My question is why is this happening? Is this a bug I should report?

I can correct it by manually adding a line for Template::Toolkit, but this is not a good solution since it will get blown away the next time I update.

Thanks


wickedxter
User

Sep 16, 2012, 2:17 AM

Post #2 of 2 (3097 views)
Re: [bluedome] minicpan puzzle [In reply to] Can't Post

template toolkit module is installed by useing cpan template .... is the package not template::toolkit its just template

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives