CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Beginner:
Trouble Installing Module

 



mcguinnessdr
New User

Sep 22, 2012, 9:11 AM

Post #1 of 3 (1741 views)
Trouble Installing Module Can't Post

Hello, I am trying to follow these [https://github.com/alexrj/Slic3r/wiki/Running-Slic3r-from-git-on-Windows] instructions to install Slic3r from source, but am having problems installing the dependencies. I have installed Citrusperl, and have run the "cpan JSON App::cpanminus" command, but when I try to run "cpanm https://github.com/alexrj/Math-Libm/tarball/master" I get the error "No Perl script found in input. I also tried downloading it and installing it manually, but after running "make" (I already ran perl Makefile.pl) I get the error:

process_begin: CreateProcess(NULL, rem, ...) failed.
make (e=2): The system cannot find the file specified.
make: *** [blibdirs] Error 2

Does anyone know why I'm getting these errors or how I can fix them? Thanks!


kola4help
Novice

Sep 23, 2012, 8:01 AM

Post #2 of 3 (1697 views)
Re: [mcguinnessdr] Trouble Installing Module [In reply to] Can't Post

pls check the following

perl -v

and the presence of make command


and also...try with nmake/dmake


(This post was edited by kola4help on Sep 23, 2012, 8:04 AM)


mcguinnessdr
New User

Sep 23, 2012, 8:34 AM

Post #3 of 3 (1690 views)
Re: [kola4help] Trouble Installing Module [In reply to] Can't Post

The dmake command seems to have worked, thank you!

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives