CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Beginner:
do i need Make - coruious errors all along the day



Oct 28, 2012, 6:36 AM

Post #1 of 4 (1868 views)
do i need Make - coruious errors all along the day Can't Post

hello -

on my notebook i wanted to run A SCRIPT - i got errors over errors.

then i decided to install WWW-Mechanize-Firefox-0.68.tar.gz

but i run into troubles : see the following:

  Parse errors: No plan found in TAP output 
Files=83, Tests=78, 7 wallclock secs ( 0.26 usr 0.08 sys + 4.64 cusr 0.56 csys = 5.54 CPU)
Result: FAIL
Failed 78/83 test programs. 14/78 subtests failed.
make: *** [test_dynamic] Fehler 2
one dependency not OK (MozRepl::RemoteObject); additionally test harness failed
/usr/bin/make test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:
reports CORION/WWW-Mechanize-Firefox-0.68.tar.gz
Running make install
make test had returned bad status, won't install without force
Failed during this command:
ZIGOROU/MozRepl-0.06.tar.gz : make_test NO
CORION/MozRepl-RemoteObject-0.34.tar.gz : make_test NO one dependency not OK (MozRepl)
CORION/WWW-Mechanize-Firefox-0.68.tar.gz : make_test NO one dependency not OK (MozRepl::RemoteObject); additionally test harness failed

well the question of the day is the following:

do i need make!?

pl lemme know.. thx alot..


Oct 28, 2012, 7:13 PM

Post #2 of 4 (1859 views)
Re: [dilbert] do i need Make - coruious errors all along the day [In reply to] Can't Post

make sure that the plugin for firefox is active MozRepl i know when i installed that add-on i had to activate it and also alow it to accept connections.

whats the command your useing to install the module? from cpan command? you can force it to install or download app::cpanm and use cpanm to install it sometimes if one fails the other sometimes will work...


Oct 29, 2012, 2:23 AM

Post #3 of 4 (1848 views)
Re: [wickedxter] do i need Make - coruious errors all along the day [In reply to] Can't Post

hello and good day

thx for answering:

running opensuse 12.2

i try to install with

install www::mechanize::firefox

as for the note: well i guess you were refering this one here:

if i have a closer look at the mozilla FF i see that the mozrepl is installed and the activation button is allready clicked [too]

but wait: i

Quote: citation of the isntruction:

3. Start mozrepl in Firefox by going to the menu: "Tools" -> "MozRepl" -> "Start" You may want to tick the "Activate on startup" item.
If tests still fail, especially t/50-click.t and 51-mech-submit.t , this might be because you use the NoScript Mozilla extension and have it blocking Javascript for file:// URLs. While this is good, the tests need Javascript enabled.

Solution: 1. Open t/50-click.html in Firefox 2. Allow Javascript for all file:// URLs 3. Re-run tests 4. No test should fail

i am not very sure if i have the NoScript-Mozilla extension - but 100% sure is that i have it blocking JavaScript for file://Urls

well what should i do here - now!?

update: well i see that javascript is enablet - what should i do now!? How can i proceed

love to hear from you


BTW - what if i want to have the list of urls in a file - like so:

open(INPUT, "<urls.txt") or die $!;

This is my source ... see a snippet [example]of the sites i have in the url-list.

urls.txt [the list of sources in a file]

Code - and so on and so forth...:

#my $fork = Parallel::ForkManager->new(2);  

my @urls = qw(;
#temp base dir
my $temp = '/home/aaron/cgi-bin/';

question: can i do like this - can i add a list of urls in a file to your forking-description (you were showin in the other thread)?

many many greetings



Oct 29, 2012, 2:29 AM

Post #4 of 4 (1847 views)
Re: [dilbert] do i need Make - coruious errors all along the day [In reply to] Can't Post

Installed WWW-Mechanize-Firefox and got very very bad response from terminal

guess you were refering this one here:

first review:
This is a great addon but this version doesn't work with firefox 8.0.
I know that they is a version that works with firefox 8.0 but i can't find a xpi version of this version.
Is there anywhere this version in .xpi file in the Internet?
If there isn't, can I make a .xpi version of this mozrepl version and give it into the Internet. I simply need use the mozrepl to one of my programm and I need to give it my clients in the most simply way.

second review
Unfortunately I had to fall back to Version 1.1beta2. After upgrading to Version 1.1 on 12/15/2011 - Keeform (an addon to Keepass) was no longer autofilling form fields. Hey I know FF v3.6.25 is old - but comments indicate that it is still supported by MozRepl.
*Updated 12/21/11* - Very Kind of the developer to respond here - and I too have re-checked/reinstalled using latest MozRepl - now under FFv.3.6.25 - with the same results. The V1.1beta2 version from GitHub works - but not the version available here. Not looking for a fix / just sharing my experience - so if someone else has the same problem - they can find a version that may works for them.

question: probably the mozrepl does not work with my version of Mozilla!?

have to check this later the day

right now i am not at home



Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives