CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Advanced:
Problem in clicking link using IEAutomation


New User

Jan 22, 2013, 3:17 AM

Post #1 of 2 (3382 views)
Problem in clicking link using IEAutomation Can't Post


I wants to click the link which contains the image over it in perl IEAutomation.

The html source code for that link is given below

. <td id='KEY_TOOLTIP_Export_Table_View' class='IconSpacing'> <a id='TLB_KEY_TOOLTIP_Export_Table_View' href="javascript:getCheckedList('/pmsmart/Request?Key=pop_export_item_tableview&OwnerType=Prj&OwnerID=181893&ItemType=Siu&DisplayCategory=Issue&DispCatEng=Issue&SearchCount=11&IsRootFolder=false&NSPs=Y','Please select Issue to edit',false)" title="Export Issue Table View" > <img src='images/export_projects.gif?RN=6.3_HF14' width='16' height='16' border='0' /> </a> </td>

The perl code am having is given below.

use Win32::IEAutomation;

my $ie = Win32::IEAutomation->new( visible => 1, maximize => 1);


But it is not clicking that link which contains image.

I have attached the snapshot of the webpage also.

Anyone can tel me how to click the link?

(This post was edited by Analog on Jan 22, 2013, 3:24 AM)
Attachments: mail3.JPG (45.9 KB)

Veteran / Moderator

Jan 22, 2013, 1:52 PM

Post #2 of 2 (3375 views)
Re: [Analog] Problem in clicking link using IEAutomation [In reply to] Can't Post

No need to post your request everywhere. If I can't answer your question (I don't even really understand it) in the Beginner section, I won't be able to do any better in the Intermediate or Advanced section.


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives