CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Win32 Programming Help:
Forward slash appended to Path before filename


New User

Apr 8, 2013, 7:54 AM

Post #1 of 3 (14578 views)
Forward slash appended to Path before filename Can't Post

I am a total newbie to perl but am required to used libraries provided by my new company. I set up the source folders in my path and PERL5LIB but whenever I try to run a programme I get messages like this:
with the / appended before the pm file.
Can anyone tell me how to fix this please. I tried search this forum but putting the \/ combination seems to mess up the search.
Thank you,


Apr 11, 2013, 8:22 PM

Post #2 of 3 (14550 views)
Re: [jgm27] Forward slash appended to Path before filename [In reply to] Can't Post

I have never seen this error. Lets try to narrow it down.
Store the attached programs in your path. Run them with the following commands.

perl >Case_A.txt 
perl >Case_B.txt
perl >Case_C.txt

Post the resulting txt files (and messages if any).

Case_A is "hello, world". -make sure perl works.

Case_B is the example from Getopt::Long module. -Make sure a system module loads.

Case_C prints your @INC array. Make sure directories are specified correctly.

Now try an equally simple experiment with your GetParms module. Post the code and all results.
Good Luck,
Attachments: (25 B) (0.25 KB) (13 B)

New User

Apr 12, 2013, 12:45 PM

Post #3 of 3 (14539 views)
Re: [BillKSmith] Forward slash appended to Path before filename [In reply to] Can't Post

Hi Bill,
Many thanks for your response and help.
I have these results:

Hello, world



Path=C:\Program Files (x86)\ImageMagick-6.8.2-Q16;C:\Program Files (x86)\ImageMagick-6.6.3-Q16;C:\Perl\site\bin;C:\Perl\bin;C:\PHP5;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\Windows\system32;C:\Windows;C:\Windows\Syst
em32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\WinSCP\;C:\Program Files\MySQL\MySQL Server 5.5\bin;C:\Program Files\TortoiseSVN\bin;c:\Program Files\Microsoft SQL Server\110\Tools\Binn\;c:\Program Files (x86)\Microsoft SQL Ser
ver\110\Tools\Binn\;c:\Program Files\Microsoft SQL Server\110\DTS\Binn\;c:\Program Files (x86)\Microsoft SQL Server\110\Tools\Binn\ManagementStudio\;c:\Program Files (x86)\Microsoft SQL Server\110\DTS\Binn\;C:\Program Files (x86)\MySQL\MySQL Server 5.1\bin
;C:\Program Files (x86)\Common Files\Acronis\SnapAPI\;c:\tools\;Z:\homeco_local\trunk\perl_libs;C:\Perl\Dwimperl\perl\bin;C:\Perl\Dwimperl\perl\site\bin;C:\Perl\Dwimperl\c\bin;C:\Program Files (x86)\GnuWin32\bin;


I have been playing around myself and in my original PERL5LIB I used \ rather than / and now I have changed this at least I am not getting the \/ issue but rather a boat load of others. Before I belabour you or any one else I will pursue a solution myself and return to this list if/when I fail.

Many thanks,


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives