CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Beginner:
installing FireFox::Mechanize & Mozrepl fails on opensuse 12.3



May 15, 2013, 11:00 AM

Post #1 of 1 (1385 views)
installing FireFox::Mechanize & Mozrepl fails on opensuse 12.3 Can't Post

hello dear all,

just managed to install opensuse 12.3 on a notebook

how to install mozrepl on this.

which way is the best one`?

note: i tried it several times - and everytime it failed.

which way is it

ps: what ingredients are needed

Perl Mechanize
Mozrepl - addon for the Web-Browser?
what else!?! is needed!!?

BTW - the OpenSuse-people are somewhat "religios ppl." they do not allow me to install via CPAN - they force me to do all the things by adding a Repository (from opensuse).

But - guess that i have to try out the CPAN-way. It seems to be a good way.
The last time i tried to install Mozrepl i did something wrong and i guess that i messed up all the machine. All the things were messed up totally.

At the end .- have had errors over errors. it was terrible.

see the error reports i have had...
btw - i guess that i somethimes have had a bad Make on the machine - or a bad make-test. What do you think"!?

here i provide you with the reports of the failed trials of installation ....

what has happened in the past: i have had serious issues with the installation of

MECHA::FireFox Hmm - i should have to work through the steps in
WWW::Mechanize::Firefox::Troubleshooting! But believe me - this is pretty hard to do: Especially the "Installation" section seems particularly applicable to my situation here!

see also...:
n i decided to install WWW-Mechanize-Firefox-0.68.tar.gz
but i run into troubles : see the following:

Parse errors: No plan found in TAP output
Files=83, Tests=78, 7 wallclock secs ( 0.26 usr 0.08 sys + 4.64 cusr 0.56 csys = 5.54 CPU)
Result: FAIL
Failed 78/83 test programs. 14/78 subtests failed.
make: *** [test_dynamic] Fehler 2
one dependency not OK (MozRepl::RemoteObject); additionally test harness failed
/usr/bin/make test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:
reports CORION/WWW-Mechanize-Firefox-0.68.tar.gz
Running make install
make test had returned bad status, wont install without force
Failed during this command:
ZIGOROU/MozRepl-0.06.tar.gz : make_test NO
CORION/MozRepl-RemoteObject-0.34.tar.gz : make_test NO one dependency not OK (MozRepl)
CORION/WWW-Mechanize-Firefox-0.68.tar.gz : make_test NO one dependency not OK (MozRepl::RemoteObject); additionally test harness failed

,,,,,also interesting - some reports (in the past!!):

If i run the script i got fatal errors -

linux-vi17:/home/martin/bin # perl Failed to connect to , problem connecting to "localhost", port 4242:
connecting to the denied at /usr/lib/perl5/site_perl/5.12.3/MozRepl/ line 144

what is aimed:

i have a list of 2,500 URLs, one on each line, saved in a file. i want the script to open the file, read a line, then retrieve the website? If so, something like this:

Filename: urls.txt
and so on and so forth...

Then the code:

use WWW::Mechanize::Firefox;
my $mech = WWW::Mechanize::Firefox->new();

open(INPUT, "urls.txt") or die "Can't open file: $!";

while (<INPUT>) {
my $png = $mech->content_as_png();


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives