CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Intermediate:
mod_perl install error (build perl with -Dusethreads)


New User

Jun 19, 2013, 7:49 PM

Post #1 of 2 (2123 views)
mod_perl install error (build perl with -Dusethreads) Can't Post

I am installing mod_perl/2.0.7 and having Apache/2.2.22 and Perl/v5.18.0 installed already.

While installing mod_perl I am getting the following error:

 file /install/perl/v5.18/bin/perl
/install/perl/v5.18/bin/perl: ELF 64-bit LSB executable, AMD x86-64, version 1 (SYSV), for GNU/Linux 2.6.9, dynamically linked (uses shared libs), for GNU/Linux 2.6.9, not stripped

 Command I am using to build mod_perl is:
/install/perl/v5.18/bin/perl Makefile.PL MP_APXS=/export/apache/bin/apxs

Error I am getting:
Reading Makefile.PL args from @ARGV
MP_APXS = /export/apache/bin/apxs
no conflicting prior mod_perl version found - good.
Configuring Apache/2.2.22 mod_perl/2.0.7 Perl/v5.18.0
[ error] Using Perl 5.018000 w/o ithreads and 'worker' mpm httpd.
[ error] Failed requirements:
[ error] - Perl built with ithreads (build perl with -Dusethreads)

As recommended in the last line – “build perl with –Dusethreads” I tried installing perl with –Dusethreads but the same error.

Any help will be appreciated.


(This post was edited by rommelsharma on Jun 20, 2013, 7:35 AM)

New User

Jun 20, 2013, 7:34 AM

Post #2 of 2 (2104 views)
Re: [rommelsharma] mod_perl install error (build perl with -Dusethreads) [In reply to] Can't Post


The issue got resolved after I used the following options and rebuilt Perl.

In the folder where perl .gz file was uncompressed:

- make distclean
- CFLAGS='-m64 -mtune=nocona'
- ./Configure -Dusethreads -Dprefix=/install/perl/v5.18 -des -A ccflags=-fPIC

Verified using:

/install/perl/v5.18/bin/perl -V:useithreads -V:usemultiplicity

Result should be like:

I also upgraded mod_perl to 2.0.8 to get over another error message that is discussed here:

It works fine now, thanks.


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives