CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: General Discussions: General Questions:
Question? Cpan dependency depth?

 



cptkrf
New User

Nov 28, 2013, 11:17 AM

Post #1 of 1 (9555 views)
Question? Cpan dependency depth? Can't Post

I was playing with a raspberry pi (with a full load of debian wheezy) just to see what it would do. I decided to try an simple stock quote download so I could use the incoming info to play with the little lcd display.

Naturally, Cpan has a module to do just that. Butů

I do the normal Makefile.PL and it works but I get the usual warnings:prerequisite xxx missing for three modules. Fairly normal.

Butů

The first sub module also had five missing prereqs. The second had three and the third had 17!

Then, each of those sub-sub modules had from one to eight more prereqs, then those sub-sub-sub modules hadů and so on. Dozens and dozens if not hundreds of modules that have to be downloaded, compiled and installed. For one fairly small and five star rated program.

The version of perl that came with the OS is 5.14.2.

So, I backed off of that model and tried different Cpan module and got into the same dependency hell. I have used Cpan for years and never got these gigantic trees of missing modules. Would this canned version of Debian have stuff missing that you would get on the normal net install on a full sized machine?

Anybody got any ideas?

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives