CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Beginner: problem.


New User

Dec 9, 2013, 8:22 AM

Post #1 of 4 (1563 views) problem. Can't Post

I am trying to install Crypt-PasswdMD5-1.40 on a Solaris 10 box and get the following -

xxxxxxxx:/tmp/Crypt-PasswdMD5-1.40# perl Makefile.PL
Writing Makefile for Crypt::PasswdMD5
, or } expected while parsing object/hash, at character offset 330 (before ""author":["Luis E. M...") at /usr/perl5/5.8.4/lib/CPAN/Meta/ line 23

I have the following version on -

package CPAN::Meta::Converter;
our $VERSION = '2.112150'; # VERSION

I have sourced a much later copy of and the problem goes away if I move it into place under /usr but this doesn't help me longterm. I don't seem to be able to find a report of this as a bug but I am guessing it has come up within the perl community before and I also don't seem to be able to find out which later version of CPAN::Meta resolved this or which earlier version is still good.

Can anyone offer any pointers? Thanks in advance.

Veteran / Moderator

Dec 9, 2013, 8:43 AM

Post #2 of 4 (1560 views)
Re: [zeroburn] problem. [In reply to] Can't Post

Why not upgrade to the latest version?

You could try only upgrading, but it would probably be best to upgrade CPAN and as part of that upgrade I suspect will also be upgraded.

Veteran / Moderator

Dec 9, 2013, 8:53 AM

Post #3 of 4 (1556 views)
Re: [zeroburn] problem. [In reply to] Can't Post

FYI, there have been 24 releases since v2.112150 and the newest one was just released 6 days ago.

If you really want to know which vision this issue was corrected in, you'll need to look over the change log for each of those versions.

New User

Dec 9, 2013, 8:56 AM

Post #4 of 4 (1555 views)
Re: [FishMonger] problem. [In reply to] Can't Post

The issue I have is I am trying to build solaris packages for deployment to a number of servers, I have taken a look at the latest version and when I try and install it I get 5 prereqs (that could lead to more) which is something I would like to avoid. I am wondering if it was resolved in a version closer to the one I have installed and may avoid some of this extra work.


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives