CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Beginner:
tried to install peewee on opensuse version 13.1



Jul 8, 2014, 12:14 PM

Post #1 of 2 (932 views)
tried to install peewee on opensuse version 13.1 Can't Post

try to install orm peewee on opensuse 13. 1

but unfortunatly it failed

this was the way i tried to install it:

martin@linux-70ce:~> git clone
Klone nach 'peewee'...
remote: Reusing existing pack: 5673, done.
remote: Counting objects: 13, done.
remote: Compressing objects: 100% (13/13), done.
remote: Total 5686 (delta 2), reused 0 (delta 0)
Empfange Objekte: 100% (5686/5686), 3.54 MiB | 102.00 KiB/s, done.
Löse Unterschiede auf: 100% (3468/3468), done.
Prüfe Konnektivität... Fertig
martin@linux-70ce:~> cd peewee
martin@linux-70ce:~/peewee> python install
running install
error: can't create or remove files in install directory

The following error occurred while trying to add or remove files in the
installation directory:

[Errno 13] Permission denied: '/usr/lib/python2.7/site-packages/test-easy-install-5717.write-test'

The installation directory you specified (via --install-dir, --prefix, or
the distutils default setting) was:


Perhaps your account does not have write access to this directory? If the
installation directory is a system-owned directory, you may need to sign in
as the administrator or "root" account. If you do not have administrative
access to this machine, you may wish to choose a different installation
directory, preferably one that is listed in your PYTHONPATH environment

For information on other options, you may wish to consult the
documentation at:

Please make the appropriate changes for your system and try again.


what can i do now

(This post was edited by dilbert on Jul 8, 2014, 12:43 PM)

Veteran / Moderator

Jul 8, 2014, 1:01 PM

Post #2 of 2 (928 views)
Re: [dilbert] tried to install peewee on opensuse version 13.1 [In reply to] Can't Post

Why ask a python related question on a Perl forum?

Does it fail if you login as root before trying to install?

If that doesn't solve the issue, then maybe ask on a python forum.


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives