CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Beginner:
Problems with PP on Linux Centos 6.7

 



popeye
Novice

Nov 7, 2015, 1:30 PM

Post #1 of 1 (1023 views)
Problems with PP on Linux Centos 6.7 Can't Post

Im on a Linux Centos 6.7 VM.

I installed pp and Par, Par:Packer using cpan.

When I attempt to create an executable.

[root@localhost unsupported-tools]# pwd
/usr/lib64/nss/unsupported-tools

[root@localhost unsupported-tools]# more pops.pl

Code
#!/usr/bin/perl 
print "Sup popeye\n";

[root@localhost unsupported-tools]# ./pops.pl
Sup Popeye


[root@localhost unsupported-tools]# ./pp pops.pl
Usage: pp [-t type] [-a] [-i input] [-o output] [-w] [-u]
Pretty prints a file containing ASN.1 data in DER or ascii format.
-t type Specify input and display type: private-key (sk),
public-key (pk), certificate (c), certificate-request (cr),
certificate-identity (ci), pkcs7 (p7), crl or name (n).
(Use either the long type name or the shortcut.)
-a Input is in ascii encoded form (RFC1113)
-i input Define an input file to use (default is stdin)
-o output Define an output file to use (default is stdout)
-w Don't wrap long output lines
-u Use UTF-8 (default is to show non-ascii as .


attempt 2
[root@localhost unsupported-tools]# ./pp -o outfile pops.pl
Usage: pp [-t type] [-a] [-i input] [-o output] [-w] [-u]
Pretty prints a file containing ASN.1 data in DER or ascii format.
-t type Specify input and display type: private-key (sk),
public-key (pk), certificate (c), certificate-request (cr),
certificate-identity (ci), pkcs7 (p7), crl or name (n).
(Use either the long type name or the shortcut.)
-a Input is in ascii encoded form (RFC1113)
-i input Define an input file to use (default is stdin)
-o output Define an output file to use (default is stdout)
-w Don't wrap long output lines
-u Use UTF-8 (default is to show non-ascii as .)

[root@localhost unsupported-tools]# ls
atob btoa derdump hello outfile selfserv strsclnt tst.bak vfychain
bltest pops.pl fipstest ocspclnt pp shlibsign symkeyutil tstclnt vfyserv

[root@localhost unsupported-tools]# ls -l outfile
-rw-r--r--. 1 root root 0 Nov 7 13:20 outfile

[root@localhost unsupported-tools]# chmod +x outfile

[root@localhost unsupported-tools]# ./outfile


Am I doing something wrong. I did notice the following on install :

Warning: prerequisite ExtUtils::Embed 0 not found.
ERROR from evaluation of /root/.cpan/build/PAR-Packer-1.026-VUA983/myldr/Makefile.PL: Can't locate ExtUtils/Embed.pm in @INC (@INC contains: /root/.cpan/build/PAR-Packer-1.026-VUA983/inc /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 /root/.cpan/build/PAR-Packer-1.026-VUA983 .) at ./Makefile.PL line 11.
BEGIN failed--compilation aborted at ./Makefile.PL line 11.
Warning: No success on command[/usr/bin/perl Makefile.PL INSTALLDIRS=site]
RSCHUPP/PAR-Packer-1.026.tar.gz
/usr/bin/perl Makefile.PL INSTALLDIRS=site -- NOT OK
Running make test
Make had some problems, won't test
Running make install
Make had some problems, won't install


Can you provide any help ?
Thanks have a great day !!

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives