CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Home: Perl Programming Help: Beginner:
CPAN fails to install locally


New User

Feb 10, 2016, 4:21 AM

Post #1 of 1 (1668 views)
CPAN fails to install locally Can't Post

Hello Everybody,

I use a server of the university I work at, where I don't have admin rights. Since I
need Perl on that server, I tried alocal install of Perl. While I can run Perl now, I
cannot install any packages with CPAN. It seems as if there is a problem with the
@INC parameter.

Having the server admin install Perl is not an option. And even if, I would still
have to install packages locally. I tried manually donwloading the packages one
by one, but I ended up in in dependency-hell (YAML).
It would be great if someone could help me with that!


Here a (shortened) example of an installation attempt

cpan[1]> install CPAN::DistnameInfo 
CPAN: Storable loaded ok (v2.53_01)
Reading '/data/home/shams/raltwass/.cpan/Metadata'
Database was generated on Wed, 10 Feb 2016 00:17:02 GMT
Running install for module 'CPAN::DistnameInfo'
CPAN: Digest::SHA loaded ok (v5.95)
CPAN: Compress::Zlib loaded ok (v2.068)
Checksum for /data/home/shams/raltwass/.cpan/sources/authors/id/G/GB/GBARR/CPAN-DistnameInfo-0.
12.tar.gz ok
Scanning cache /data/home/shams/raltwass/.cpan/build for sizes
CPAN: File::Temp loaded ok (v0.2304)
'YAML' not installed, will not store persistent state
CPAN: CPAN::Meta::Requirements loaded ok (v2.132)
CPAN: Parse::CPAN::Meta loaded ok (v1.4414)
CPAN: CPAN::Meta loaded ok (v2.150001)
CPAN: Module::CoreList loaded ok (v5.20151213)
Configuring G/GB/GBARR/CPAN-DistnameInfo-0.12.tar.gz with Makefile.PL
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for CPAN::DistnameInfo
Writing MYMETA.yml and MYMETA.json
/data/home/shams/raltwass/programme/perl/bin/perl5.22.1 Makefile.PL PREFIX=/data/home/shams/r
altwass/programme/perl -- OK
Running make for G/GB/GBARR/CPAN-DistnameInfo-0.12.tar.gz
/usr/bin/make -- OK
Running make test
PERL_DL_NONLAZY=1 "/data/home/shams/raltwass/programme/perl/bin/perl5.22.1" "-MExtUtils::Comman
d::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'bli
b/arch')" t/*.t
t/ext.t ... Can't locate CPAN/ in @INC (you may need to install the CPAN::Distna
meInfo module) (@INC contains: /data/home/shams/raltwass/.cpan/build/CPAN-DistnameInfo-0.12-cmX
Q16/blib/lib /data/home/shams/raltwass/.cpan/build/CPAN-DistnameInfo-0.12-cmXQ16/blib/arch /dat
a/home/shams/raltwass/programme/perl /data/home/shams/raltwass/programme/perl/lib/5.22.1/x86_64
-linux /data/home/shams/raltwass/programme/perl/lib/5.22.1/x86_64-linux /data/home/shams/raltwa
ss/programme/perl/lib/5.22.1 /data/home/shams/raltwass/programme/perl /data/home/shams/raltwass
/programme/perl/lib/5.22.1/x86_64-linux /data/home/shams/raltwass/programme/perl/lib/5.22.1 /da
ta/home/shams/raltwass/programme/perl/lib/5.22.1/x86_64-linux /data/home/shams/raltwass/program
me/perl/lib/site_perl/5.22.1/x86_64-linux /data/home/shams/raltwass/programme/perl/lib/site_per
l/5.22.1 /data/home/shams/raltwass/programme/perl/lib/site_perl/5.22.1/x86_64-linux /data/home/
shams/raltwass/programme/perl/lib/site_perl/5.22.1/x86_64-linux /data/home/shams/raltwass/progr
amme/perl/lib/site_perl/5.22.1 /data/home/shams/raltwass/programme/perl/lib/5.22.1/x86_64-linux
/data/home/shams/raltwass/programme/perl/lib/5.22.1 .) at t/ext.t line 5.
BEGIN failed--compilation aborted at t/ext.t line 5.
# Looks like your test exited with 2 before it could output anything.
t/ext.t ... Dubious, test returned 2 (wstat 512, 0x200)
Failed 560/560 subtests
[.. CUT OUT ...]
Test Summary Report
t/ext.t (Wstat: 512 Tests: 0 Failed: 0)
Non-zero exit status: 2
Parse errors: Bad plan. You planned 560 tests but ran 0.
t/path.t (Wstat: 512 Tests: 0 Failed: 0)
Non-zero exit status: 2
Parse errors: Bad plan. You planned 269 tests but ran 0.
Files=2, Tests=0, 1 wallclock secs ( 0.04 usr 0.04 sys + 0.06 cusr 0.12 csys = 0.26 CPU)
Result: FAIL
Failed 2/2 test programs. 0/0 subtests failed.
make: *** [test_dynamic] Error 2
/usr/bin/make test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:
reports GBARR/CPAN-DistnameInfo-0.12.tar.gz
Failed during this command:
GBARR/CPAN-DistnameInfo-0.12.tar.gz : make_test NO

Here is my conf:

$CPAN::Config options from /data/home/shams/raltwass/.cpan/CPAN/ 
commit [Commit changes to disk]
defaults [Reload defaults from disk]
help [Short help about 'o conf' usage]
init [Interactive setting of all options]
applypatch []
auto_commit [0]
build_cache [100]
build_dir [/data/home/shams/raltwass/.cpan/build]
build_dir_reuse [0]
build_requires_install_policy [yes]
bzip2 [/usr/local/bin/bzip2]
cache_metadata [1]
check_sigs [0]
colorize_debug [black on_cyan]
colorize_output [1]
colorize_print [bold green on_black]
colorize_warn [bold red on_black]
commandnumber_in_prompt [1]
commands_quote undef
connect_to_internet_ok [1]
cpan_home [/data/home/shams/raltwass/.cpan]
curl undef
dontload_hash undef
dontload_list undef
ftp undef
ftp_passive [1]
ftp_proxy []
ftpstats_period undef
ftpstats_size undef
getcwd [cwd]
gpg [/usr/bin/gpg]
gzip [/bin/gzip]
halt_on_failure [0]
histfile [/data/home/shams/raltwass/.cpan/histfile]
histsize [100]
http_proxy []
inactivity_timeout [0]
index_expire [1]
inhibit_startup_message [0]
keep_source_where [/data/home/shams/raltwass/.cpan/sources]
load_module_verbosity undef
lynx undef
make [/usr/bin/make]
make_arg []
make_install_arg []
make_install_make_command [/usr/bin/make]
makepl_arg [PREFIX=/data/home/shams/raltwass/programme/perl]
mbuild_arg []
mbuild_install_arg []
mbuild_install_build_command [/Build]
mbuildpl_arg [--install_base]
ncftp undef
ncftpget undef
no_proxy []
pager [/usr/bin/less]
password undef
patch [/usr/bin/patch]
patches_dir undef
perl5lib_verbosity [none]
prefer_external_tar [1]
prefer_installer [MB]
prefs_dir [/data/home/shams/raltwass/.cpan/prefs]
prerequisites_policy [follow]
proxy_pass undef
proxy_user undef
randomize_urllist undef
recommends_policy [1]
scan_cache [atstart]
shell [/bin/bash]
show_unparsable_versions [0]
show_upload_date [0]
show_zero_versions [0]
suggests_policy [0]
tar [/bin/tar]
tar_verbosity [none]
term_is_latin [1]
term_ornaments [1]
test_report [0]
trust_test_report_history [0]
unzip [/usr/bin/unzip]
0 []
1 []
2 []
use_prompt_default [0]
use_sqlite [0]
username undef
version_timeout [15]
wait_list undef
wget [/usr/bin/wget]
yaml_load_code [0]
yaml_module [YAML]

And here my $PERL5LIB:


(This post was edited by haumich on Feb 10, 2016, 4:28 AM)


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives