CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Beginner:
AAargh! Please help me :)

 



d7n13l
Deleted

Jan 31, 2001, 9:12 AM

Post #1 of 5 (867 views)
AAargh! Please help me :) Can't Post

OK - Someone please help me before I throw this stupid machine out the window :)

I am trying to get some perl script running on a local machine via the cgi-bin of my web server. All i get, though, is either, a) a very slowly moving progress bar, b) a 'save this file to disk' dialog or c) a CGI time-out error. Oh yeah and sometimes I get a 'read permissions error' too !

This is my set-up:

Installed PWS 4.0 straight off the MS Win98 SE CD

Downloaded and installed ActivePerl-5.6.0.623-MSWin32-x86-multi-thread.msi from www.activestate.com

Made ammendments to the 'Script Map' section of the registry (.cgi "C:\Perl\bin\Perl.exe %s %s", .pl "C:\Perl\bin\Perl.exe %s %s")

Created an Explorer file-association (.pl, C:\PERL\BIN\PERL.EXE "%1" %*)

Set the permissions with PWS on the folders ( wwwroot is set to read execute scripts and wwwroot/cgi-bin is set to execute)

Added the Perl path to AUTOEXEC.BAT (SET PATH=C:\Perl\bin;%PATH%)

I'm positive all this is set up exactly as it is on my home machine and that runs fine?!!!

I'm running Windows 98 SE

If anyone can spot the deliberate mistake (...) I'll love them forever :)



sleuth
Enthusiast

Jan 31, 2001, 11:45 PM

Post #2 of 5 (855 views)
Re: AAargh! Please help me :) [In reply to] Can't Post

 
Awe Mate, I feel you pain,

What your missing is the DCOM module needed to run Active Perl on windows 98 and less. Windows 200 comes with it. You can get it here,

http://www.microsoft.com/com/resources/downloads.asp

Look for DCOM for windows 98.

After you install that it will work.

Best of luck to you Mate,

Tony



d7n13l
Deleted

Feb 1, 2001, 12:13 AM

Post #3 of 5 (852 views)
Re: AAargh! Please help me :) [In reply to] Can't Post

Thanks Tony, but I do already have DCOM98 installed. My fault - I forgot to mention that :) ANy other ideas?



d7n13l
Deleted

Feb 1, 2001, 12:27 AM

Post #4 of 5 (851 views)
Re: AAargh! Please help me :) [In reply to] Can't Post

This gets weirder! I've gone into a command prompt and got the Perl version info to display correctly (C:\PERL\BIN\ perl -v). I've also run the 'example.pl' script from the command prompt and got the right message back (hello from ActivePerl). Whassgoingon? The problem is obviously with the link between my browser (IE 5.5) and ActivePerl. I'm gonna cry in a minute :)



sleuth
Enthusiast

Feb 1, 2001, 12:02 PM

Post #5 of 5 (842 views)
Re: AAargh! Please help me :) [In reply to] Can't Post

 Hey, There is a list of instructions here

http://forums.perlguru.com/showflat.pl?Cat=&Board=Forum11&Number=6601&page=0&view=collapsed&sb=5

Go there and start all over, uninstall everything and start over following those dirctions, I wrote those out while installing it successfully on my own wind98 pc.

Tony



(This post was edited by Jasmine on Feb 1, 2001, 8:11 PM)

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives