CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Intermediate:
Control::CLI; telnet does not work with special OS

 



dhiab
New User

Apr 17, 2016, 4:58 AM

Post #1 of 5 (4037 views)
Control::CLI; telnet does not work with special OS Can't Post

Gents,
i have a telecom machine, 2G BSC, with special OS supports telnet but when i use perl Telnet it ends with err timeOut as below, any ideas?

--------------------
Control::CLI-waitfor:read timed-out at ./cliConnect.pl line 6


Laurent_R
Veteran / Moderator

Apr 17, 2016, 10:30 AM

Post #2 of 5 (4035 views)
Re: [dhiab] Control::CLI; telnet does not work with special OS [In reply to] Can't Post

Please show your code.

And provide more details: for example, can you connect with interactive Telnet?

We can't guess what might go wrong with so little information.


dhiab
New User

Apr 17, 2016, 10:44 AM

Post #3 of 5 (4033 views)
Re: [Laurent_R] Control::CLI; telnet does not work with special OS [In reply to] Can't Post

interact telnet works fine,

[root@rc02vm21 sysReset]# ./telnet.pl
timed-out waiting for login prompt at ./telnet.pl line 7

#!/usr/bin/perl

use Net::Telnet ();
my ($username,$passwd,$host)=('NUPADM','ADMNUP','10.163.252.44');
$t = new Net::Telnet (Timeout => 10);
$t->open($host);
$t->login($username, $passwd);
@lines = $t->cmd("ZIGO;");
print @lines;
--------------------------
interact telnet looks:

[root@rc02vm21 sysReset]# telnet 10.163.252.44
Trying 10.163.252.44...
Connected to 10.163.252.44.
Escape character is '^]'.

ENTER USERNAME < NUPADM

ENTER PASSWORD < ******

mcBSC HA1BSCN01 2016-04-17 20:42:08

WELCOME TO THE DX 200 SERIES DIALOGUE

MAIN LEVEL COMMAND <___>
< ZQEI;


LOADING PROGRAM VERSION 4.3-0

mcBSC HA1BSCN01 2016-04-17 20:42:17

INTERROGATING CLNS

NODE IN ES ROLE

/*** CLNS DOES NOT EXIST IN DATABASE ***/

COMMAND EXECUTED


OSI ENVIRONMENT CONNECTIONLESS NETWORK SERVICE HANDLING COMMAND <QE_>
<


(This post was edited by dhiab on Apr 17, 2016, 10:49 AM)


Laurent_R
Veteran / Moderator

Apr 18, 2016, 7:25 AM

Post #4 of 5 (4019 views)
Re: [dhiab] Control::CLI; telnet does not work with special OS [In reply to] Can't Post

And what is the "ZIGO;" command supposed to do? Are ou sure it requires a semi-colon? What OS is the distant host?


dhiab
New User

Apr 18, 2016, 8:35 AM

Post #5 of 5 (4016 views)
Re: [Laurent_R] Control::CLI; telnet does not work with special OS [In reply to] Can't Post

thanks for reply.
any cmd should be appended with ; to execute it, sample output as snapshot attached. OS is Nokia DX200 and this machine is controller for 2G sites.
Attachments: ZEEL-output.PNG (13.8 KB)

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives