CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Advanced:
using perl in aspx page

 



sking
New User

Feb 4, 2017, 10:38 PM

Post #1 of 1 (3249 views)
using perl in aspx page Can't Post

I have a perl script that I use in a asp.net page. The user is logged in to a folder (authenticated) and there is a long form with the action="url" method ="POST" that posts the form data to the script.

This is working fine on one of my websites in asp.net (VB) When you click the submit button at the bottom of the form, there are diagnostics in case you didn't input all of the required fields, it will tell you which ones you missed.

I get this on both sites, but what I don't get is after you have input all the required fields, when you click the submit button, the script should complete its operation and refer to a thank you page. What happens is there is another invalid field that is stuck in the array of form fields.
(name, value) and it is an asp.net generated field. Field ctl00%24ContentPlaceHolder1%24userid not exist! at 257

foreach(@field){error("Field $_ not exist! at 257") if !$field{$_};}
open(F, ">>$base_file") || error("Can't open file $base_file at 258!");
print F "$line\n";
close F;

how is it that the @field array as this userid field in it? This ct100 blah blah is created by asp.net Also, this field is not defined as a required field.

My other website doesn't do this. The script I use is csvwrite.pl modified for my needs.


(This post was edited by sking on Feb 4, 2017, 10:39 PM)

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives